Support » Fixing WordPress » After Upgrade – wp-include/functions.php PROBLEM

  • After upgrading from wp1.2.2 to wp1.5, when someone tries to comment on my post, they always get this error message:

    Fatal error: Cannot redeclare add_magic_quotes() (previously declared in /home/flashgiz/public_html/postit.php:3) in /home/flashgiz/public_html/wp-includes/functions.php on line 1738

Viewing 2 replies - 1 through 2 (of 2 total)
  • Scott Reilly

    (@coffee2code)

    WordPress & Plugin Developer

    Looks like you have a file in your web directory called postit.php which has defined a function with a name that WordPress also is looking to use. Remove postit.php.

    I had the same problem – I had renamed wp-comments-post.php in an effort to reduce comment spam, and kept my modified 1.2 template when I upgraded to 1.5. Deleting the extra file and changing the comment-posting code in index.php fixed it.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘After Upgrade – wp-include/functions.php PROBLEM’ is closed to new replies.