Support » Plugin: Manual Image Crop » After upgrade to WP 5.2.4: {“status”:”error”,”message”:”wrong attachement”}

  • helmsberger

    (@helmsberger)


    Hello…
    I realize that the Plugin is no longer being supported, but this problem has just started for me after upgrading to WordPress 5.2.4, when I go to crop an image:

    {“status”:”error”,”message”:”wrong attachement”}

    I’ve traced it down to $postId being empty in ManualImageCropEditorWindow.php on line 41 due to $_GET[‘postId’] returning null… but don’t know what to do from there.

    Any ideas?

    Thanks in advance _/|\_
    Boaz

Viewing 1 replies (of 1 total)
  • This is due to this core bug – https://core.trac.wordpress.org/ticket/48236 – due for a fix in 5.4. in the meantime I think you will have to apply the patch manually – edit /wp-includes/js/media-views.js replacing line 8972:

    attributes: {},

    with:

    attributes: function() { 
        return {
            'data-id': this.model.get( 'id' )
        };
    },

    …then replace the contents of wp-includes/js/media-views-min.js (the js file that is actually loaded in admin) with your edited version.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.