Support » Fixing WordPress » After upgrade to WP 3.5 blog's homepage redirects to static html homepage

  • I cannot figure this out on my own, and am desperate to get this fixed. I am hoping that one of you very helpful WP experts can come to my rescue.

    Part 1 of my post has been “closed” and is here:

    My set-up is as follows:
    I have a main static html website ( and three WP blogs that are set up as sub-domains.
    I have not changed themes. I am running Thesis 1.8.5 on all three blogs.
    When this happened, all I did was upgrade to Thesis 1.8.5 and WP 3.5. I did not change any WP settings or install any new plugins at the time of the upgrade. I do not believe this issue existed prior to this upgrade.

    Here is a summary of the issues I am having and list of fixes I have tried that have not worked.

    1. When you go to any of my three blogs’ homepages you are redirected to the static html website. (Because I have not had time to change the look of my blogs to match the website, it is easy to tell which one you are at. They look very different). I have posted screen shots of the homepage of my website and one of the blogs so you can see what you should see when you go to the blogs.

    The three blogs are:

    2. A *NEW* issue that I discovered is that I cannot view drafts of my posts. When I click on “preview” from the WP admin panel, it takes me to my site’s static html homepage ( rather than a preview of the blog post. I am not sure how this is related…but it seem to me that it is.

    1. Disabled all plugins. This did not work.
    2. Changed the permalink structure from “Day and Name” to other choices.This did not work.
    3. Checked the WP .htaccess files. They all appear to be fine. All look like this (with the individual blog’s info in each one):
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /veterans-disability-blog/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /veterans-disability-blog/index.php [L]

    # END WordPress

    4. Checked with my webhost to confirm that mod_rewrite is correctly configured & running on the server. It is.
    5. Kevin (the last response to the previous post) suggested modifying httpd.conf. But I have to confess that this is WAY over my head,
    and does not appear do-able for me.
    6. My WordPress Address and Site Address urls on the General Settings page both point to the blogs’ main pages. (e.g., the Veterans’ Disability blog is set to

    [No bumping, thank you.]

  • The topic ‘After upgrade to WP 3.5 blog's homepage redirects to static html homepage’ is closed to new replies.