Support » Networking WordPress » After Upgrade to WAMP 2.4 can't view multi sites

  • Resolved Traveltech


    Howdy! I’ve just upgraded my WAMP server to version 2.4 running WordPress 3.8 with a few sub-directories running multi sites enabled and others running single installations. I have several databases for development all of which work fine after the upgrade, unless they are multi-site enabled. The issue is I can view the primary admin site from the front end and the backend, when I go to sites from the network menu I can see all the subsites I have created but when I click on them to go to the site I get a 404 error. I moved the databases via PHPMYADMIN dump. I was thinking that might have been a problem but since all the other wordpress single sites work I moved on from that course. I have tested with a fresh installation of WordPress mu enabled, created a site under the admin and I’m getting the same result. I’m thinking a config or ini issue but I am at a loss where to start. Any help would be appreciated.

Viewing 1 replies (of 1 total)
  • I’ve solved the problem. I thought it might be an .htaccess, config or ini file issue. I looked at my .htaccess file and all seemed well. Here is what it looked like while I was getting the 404 messages.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /education/
    RewriteRule ^index\.php$ - [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    # END WordPress

    This was giving me a plain 404 not found on this server error.
    I removed the <IfModule mod_rewrite.c> and </IfModule> lines
    refreshed an was given a 500 Internal Server Error “The server encountered an internal error or misconfiguration and was unable to complete your request.”
    This made me think that the Apached rewrite_module wasn’t firing and sure enough that module was not activated under the Apache modules.

    This fixed the issue and left the <IfModule mod_rewrite.c> and </IfModule> out of the .htaccess file because if included the errors are not clear about the issue.

    I hope this will help someone else having this problem. Now I can get back to my studies! 🙂

Viewing 1 replies (of 1 total)
  • The topic ‘After Upgrade to WAMP 2.4 can't view multi sites’ is closed to new replies.