Support » Fixing WordPress » After upgrade to 5.2.4: problem with babel/polyfill loaded more than once

  • Hi everybody,
    After upgrading to WP 5.2.4 (from 4.9.11) I noticed a slowing in the admin area of a site. To be true the page loads in 4/5 seconds but the loading spin continues to rotate and the page seems slow to interact with.

    On the console log I can see this:

    @babel/polyfill is loaded more than once on this page. This is probably not desirable/intended and may have consequences if different versions of the polyfills are applied sequentially. If you do need to load the polyfill more than once, use @babel/polyfill/noConflict instead to bypass the warning.

    I still can’t understand if this is due to a conflict with a specific plugin but I tried to disable one plugin at a time to see if it disappear but it keeps to rise. I also activated the nineteenine theme but same problem.

    Maybe the loading problems are due to other issues but I’d like to have a hint about what can cause the “@babel/polyfill loaded more than once” warning.

    If it can help I’m reporting here the load-scripts log:

    example .com/wp-admin/load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,utils,jquery-ui-widget,jquery-ui-position,underscore,wp-util,jquery-ui-core,jquery-ui-mouse,jquery-ui&load%5B%5D=-sortable,jquery-ui-draggable,jquery-ui-slider,moxiejs,plupload&ver=3b5f669ae92d3f4714863d4c9400d2e8

    Thanks for suggestions.

    • This topic was modified 8 months, 2 weeks ago by Webartisan.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Just to confirm, if you deactivate all plugins and revert to the default theme, this error still occurs?

    Currenlty I’m not able to deactivate all plugins all at once.

    I was wondering if it’s normal to see &load%5B%5D repeated twice in the querystring of load-scripts.php

    > Currenlty I’m not able to deactivate all plugins all at once.

    How about Plugin Detective? Or testing on a staging environment?

    Thank you for the suggestion.
    I’ve tried Plugin Detective but it shows me only white screen (the same on another website not affected by the problem of this thread, I already asked on the support of PD).

    Maybe when I have time will try on a staging environment.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘After upgrade to 5.2.4: problem with babel/polyfill loaded more than once’ is closed to new replies.