Support » Plugin: WordPress HTTPS (SSL) » After upgrade to 4.0

Viewing 15 replies - 1 through 15 (of 17 total)
  • I can use it with WP 4.0, the login and navigation in the dashboard works.
    But as soon as I try to save some settings, the URL scheme breaks, so the called URL is without my blog url actually, so only proxy.com/wp-admin/ … Could be related to your problem and the problem with 4.0

    I also have a redirect loop. It’s not just on admin. I also get a redirect loop if I simply access the site.

    I just figured it out for myself. Well not entirely. I had FORCE_SSL_LOGIN set to true in my wp-config.php. This now sets the entire admin to ssl. I also had Force SSL Exclusively checked in my WordPress HTTPS settings page. It appears that this causes the admin to go http and then the force login redirects to https and there is just a war.

    To solve, set remove FORCE_SSL_LOGIN to false and set FORCE_SSL_ADMIN to true. This will set the admin to always be in ssl (including wp-login.php) and force http on all pages that do not have FORCE_SSL.

    Hope this helps everyone out there.

    I don’t see those lines in my wp-config.php file. Did you add it manually?

    Is this plug-in still actively being maintained? It doesn’t look like it’s been updated in a while – can we get some clarity from the developer on WP 4.x support?

    Same issue today… Cannot login to my WP subdomain page… Getting a redirect loop to root admin page. Deleted entire plugin to get access back. Any other simple plugin options out there for turning on HTTPS?

    Same issue here too.

    Will post if i find a solution.

    same issue here with WPMU after upgrading today to 4.0.

    The upgrade changed the default URLs to https, creating a loop which locked me out of login and admin. Had to use phpMyAdmin to edit them back to http (they’re in the wp-options table).

    Does anyone have a fix to the issue and managed to use WordPress Https Plugin cohesively with WordPress v 4.0?

    Same problem here. Deactivated the plugin and all works fine.

    Same issues here. Also with the plugin uninstalled: http://wordpress.org/support/topic/wordpress-40-in-a-ssl-loop

    richardknight

    (@richardknight)

    yup me to, doesmt work under 4.

    Beware !

    Benjamin Denis

    (@rainbowgeek)

    No problem with WP 4.0 for me (WPML+WOOCOMMERCE+bbPress+Gravity Forms)

    Shonu

    (@shonu)

    Whoever has issues on non-admin/site pages, try clearing your cookie. I had frontend loops to login page when transitting from WP3.x to 4.0 and clearing the cookie at least managed access.
    Still sad that this seems to be the only promissing SSL plugin (I think “WordPress SEO by Yoast” has SSL option as well) but is not maintained anymore.

    Not sure why the author (though we are very thankful) does not come back to us. I am happy to contribute something if I know that it is maintained.

    Shonu

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘After upgrade to 4.0’ is closed to new replies.