[closed] After Upgrade to 3.3, Visual Editor Fails (59 posts)

  1. Breigh
    Posted 4 years ago #

    Clearing the cache made no difference, will report back on the manual upgrade.

  2. Breigh
    Posted 4 years ago #

    I saw in another thread that people tried the "Use Google Libraries" plugin to fix the problem. I tried it and sure enough, it's working again! I don't know WHY, mind you, but I'm not going to ask questions. I'm just glad it works!

  3. Hoopdriver
    Posted 4 years ago #

    It all just seems to be so random - I tried the same thing, but no joy. THe thing is the rest of my site seems to be working just fine.

  4. yateha
    Posted 4 years ago #

    Thanks Breigh for that awesome tip! It worked at me! But I still hope, that there will be an update soon.

  5. Hoopdriver
    Posted 4 years ago #

    Now I am really sad - no joy for Use Google Libraries for me :-(

  6. kitllc
    Posted 4 years ago #

    "Use Google Libraries" plugin to fix the problem for me as well. Thank you sir.

  7. kitllc
    Posted 4 years ago #

    @TheResistance I installed

    "Use Google Libraries"
    plugin to fix the problem based on another recommendation in the forum and it fixed my problem. Thought I'd share it here with you sir.

  8. If Use Google Libraries is fixing it, then it sounds like your jQuery files included in WordPress (which are new 1.7.1) didn't get upgraded correctly.

    I would try deleting the wp-includes folder and then replacing ONLY that folder with a fresh copy from http://wordpress.org/download/

  9. kitllc
    Posted 4 years ago #

    @Ipstenu I'll try that now and disable the plug-in and see if that works. I'll log the upload to make sure everything goes without error as well.

    I'll be back. Thank you.

  10. robthecomputerguy
    Posted 4 years ago #

    I think I failed to mention that this problem is not necessarily site based...

    On one of the sites I am working on, people using XP & Win7 can't get the toolbar. On my Mac, a separate Win7 box and running XP in VMWare, I do not have the problem.

    I have plugins and extensions loaded up the wazoo, and they did not.

    I couldn't duplicate the problem in any browser, anywhere.

  11. THAT sounds like caching, rob.

    Tell them to hard dump their cache on their browsers.

  12. robthecomputerguy
    Posted 4 years ago #

    I thought so too.. but after deleting caches and still have it not working, I installed Safari and it happened there too!

  13. kitllc
    Posted 4 years ago #

    @Ipstenu I followed your suggestion to re-upload the wp-includes. I did so and even manually compared every file on the server with the files in the wp-include folder from the download.

    As soon as I disable the Use Google Libraries plug-in and refresh, the Visual Editor is gone.

    I Activate the plug-in once again, refresh and all is well.

    Thanks again.

  14. vincentabry
    Posted 4 years ago #

    @Theresistance : I have several blogs and your problem (edit mode) appear for me on only one. I suspect this is caused by the wordpress theme.
    Besides The top bar doesnot appear for this blog.

  15. StyleSample
    Posted 4 years ago #

    The Use Google Libraries plugin worked for me, too.

    Thanks for the suggestion!

  16. sarv007
    Posted 4 years ago #

    Yep installing Google Libraries plugin...solves the problem..Thanks Breigh!

  17. Hoopdriver
    Posted 4 years ago #

    This is getting depressing - nothing I've tried works, including the seemingly infallible Use Google Libraries. Thing is the rest of the site is just fine. Maybe I'll just have to get used to editing and composing in html until somebody makes a patch for 3.3...

  18. avinews
    Posted 4 years ago #

    Weird thing is, it seems that the pc has some influense in this as well. I still can't use visual on my laptop, but my partner some 200 Kilometers away on his laptop has no problems what so ever..

    It all works fine in Chrome, not in IE form me, for him both work fine..

  19. robthecomputerguy
    Posted 4 years ago #

    @Hoopdriver and @avinews - Avinews , you're right. Someone explained that if Use Google Libraries works for you, then you've got that code cached and your system is holding on to it. I don't know enough to vouch for that or not, but when people are solving the problem with multiple refreshes, that's true at least some of the time.

    Now this did happen to at least one person on Linux, but usually nobody is stating their operating system - I don't know anyone with this problem on Mac yet, but I'm not sure.
    (The adblocker thing applied to Linux and Mac people too, but that wasn't a persistent problem.)

    If you could both start a new thread stating the problem but state your operating system and browsers you used, and tell us what kind of security software you have installed for internet security, safe browsing, and accelerated browsing, I'm sure we can get some more layers of the onion peeled for you here.

    If someone is going to complain that such posts are inappropriate for the forum then you can post them on the comment at my blog wpgeniusbar.com where I have a post for the steps to solve this problem.

    Also, I'm going to suggest an obviously non-linear idea of installing an addon to the text editor that could hopefully force a reloading of this toolbar for you: http://wordpress.org/extend/plugins/tinymce-advanced/

    Before checking the toolbar, I'd still clear the cache after activating the plugin, log out, then log back in and see if you get something new/refreshed. If this fixes your toolbar, you should be able to remove the plugin afterward, but hey, it looks like a nice plugin.

  20. ReneODeay
    Posted 4 years ago #

    there is one more thing that has been suggested elsewhere on this problem. an english javascript file missing in the timymice folder.
    en.js goes in the wp-includes/js/tinymice/lang/ folder, you can download it from the tinymice website languages downloads. donno why but when I added that before adding the Use Google Libraries plugin, I got the commands back for the html editor. still couldn't get the visual editor to work, tried the Hotfix plugin, no go, until I added the google libraries plugin.

  21. If the file is missing, you've got an incomplete upgrade (this is why we said to do the manual upgrade).

    And Mac people have had this problem too, with Safari.

  22. ReneODeay
    Posted 4 years ago #

    Ipstenu, just downloaded a fresh WP 3.3, and checked the files in that folder, en.js is not there. to be frank, it is not in my 3.3 beta version either, which I am using in a MAMP install on my Mac. have not had the editor problem with that install tho at all, so have not used any fixes there. It is my online wordpress I have had problems with. oh, and I am using the same theme there as on my online one. (Aspire)
    my wordpress online: word.reneodeay.com
    (but do have a lightbox fail. but that is another topic)

    Oh, am using Seamonkey browser on my Mac Tiger. Safari has same problems.

  23. robthecomputerguy
    Posted 4 years ago #

    Rene thanks very much for that follow up - much appreciated, and key information for sure.

  24. malcsimm
    Posted 4 years ago #

    Hi all

    Found the thread - and the Google Libraries thing worked for me like magic - on two different blogs, two different hosts. Prior to that I had tried deactivating all plugins, and hard-clearing cache, with no result.

    Think I will wait a while before I update any more blogs!

    Thanks for the info - and sorry for the person it's not working for :-|



  25. Vance3h
    Posted 4 years ago #

    Google Libraries plugin also fixed this problem for me. Some specifics if someone is trying to troubleshoot this.

    Before the fix:
    OS Windows 7 Home Premium,
    Browsers neither Chrome or IE worked
    All plug-ins disabled
    wp-langs-en.js present in the tinymice lang directory. no "en.js" file
    Refreshed cache multiple times. Did full flush on cache in Chrome tools
    On HTML editor no commands were visible on the toolbar except media upload (which worked) HOWEVER when I checked the "Disable the visual editor when writing" box in the user profile the HTML commands in the toolbar appeared. Unchecking the box returned things to where they were.

    Installing the "use google libraries" plugin fixed the problem. Deactivating the plugin returned me to the broken visual editor status.

    I wouldn't be surprised if this is a theme related problem.

    Vance sixfigureinvesting.com

  26. 13hands
    Posted 4 years ago #

    Happy holidays everyone,...so I tried everything (OSX Snow Leopard Safari and Firefox) to no avail....didn't want to mess with .htaaccess steps I read about as I'm not a programmer per se, but can wiggle around some code....

    So now I have isolated the
    wp-includes folder from the downloaded upgrade for 3.3. Now to manually copy over the old wp-includes folder.... now this may seem like a stupid question..... I'm in WP now and can't seem to find a way to upload to replace or even find those files in the editor.......only the automatic reinstall option is available via WP, not able to reinstall 3.3 via upload from my end...

    I assume I must do this through
    my c-panel and ftp via my host company? Man, would I be forever grateful for a few more steps in order to accomplish this correctly....then activate the Use Google Libraries and hope the visual editor reappears...

    Thanks so much,
    13 HANDS

  27. Anas
    Posted 4 years ago #

    Solution :
    Step 1 : Change the theme
    Step 2 : Clear the cache
    Step 3 : Go to your editor
    Step 4 : Change to 'HTML'
    Step 5 : Change to " Visual Editor'
    Step 6 : Now you can find the Visual Editor Options
    Step 7 : Change to your original theme

    If Problem Persists, Add ' WP-Super Edit / Use Google Library ' Plugins, then check it. :)

  28. renderinnovations
    Posted 4 years ago #


    I am developing websites for clients, only 1 client out of say 20 that use wordpress is experiencing this problem. I changed the theme, cleared my cache, used 3 different browsers, etc etc added the google library and the wp-super edit and nothing. I also had another plugin that I purchased from Code Canyon called "Visual Composer".
    This plugin is another form of editor that overrides visual and you can enter awesome visual components, layouts etc. So I added this thinking that it would override visual editor but the plugin doesn't even respond.

    Would it be javascript? I also have for the client https: ssl inserted. I recently added a google meta tag and after that it just want awol.

    Still any ideas?

  29. esmi
    Forum Moderator
    Posted 4 years ago #

    Please post a new topic.

Topic Closed

This topic has been closed to new replies.

About this Topic