Support » Fixing WordPress » After Upgrade to 2.x: Number of comments shows 0 when there’s plenty of comments

  • Resolved WindyT


    We’ve done several clean installs of 2.x WP, and have upgraded a few of our 1.5x WP to the 2.x versions, and a few of the upgrades have had an issue.

    Not all of the upgrades, just three now.

    Problem. On the main page, there the post will be, and the number of comments shows as “0 Comments” with the link to make your comment. There’s plenty of comments, but the number shows 0 as in zero comments.

    The link goes to the bottom of the full page where the comment form is, and there in big blue type, “No Repsonses to (Title), even when there’s 1 or more responses.

    On the Admin Manage page, there the links are to see how many comments. “Comments (0)” with the link to the page, so this number counting issue goes even to the admin page.

    1)Standard Linux server, generic and uptodate.
    2)Posts made before the upgrade don’t show this problem.
    3)Old posts still showing the proper number of comments with the link, have the link go to the page to the #comments. BUT the new posts have the link going to the #respond. This is a huge clue, but my searching so far has turned up nothing.
    4)We’ve deleted the files and replaced anew twice now, thinking of a corrupt upload. Nothing, no change.

    Is this a comments_number issue? If so, how do I fix it?
    I thought it might be some flag that’s being written when the post is originally made, but I can’t find anything.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thread Starter WindyT


    Okay, more details.
    Three problem upgrades on the server done by the same person (not me!) from 1.5x to 2.0.3.

    Looking at JUST the database with PHPMyAdmin,
    the wp_posts table isn’t getting incremented when a comment is being made. This would answer most of the questions for display AFTER the comment is in.

    So, the database isn’t being added to correctly.

    How does the comment_count field in the wp_posts table get incremented when a new comment is made?

    EDIT: This is turning into a PLUGIN issue. I turned ’em all off, and made a reply and that self corrected that one post.

    FINAL EDIT: Old version of Spam Karma 2 was the problem.

    Thanks for this. I had the same problem. I upgraded to the latest Spam Karma, then had to manually change the database, by finding posts that received comments after the WP upgrade and changing the comment_count field to give the correct amount of comments. Now it is all incrementing properly.

    Thanks for posting followup messages! I have been having this same problem. I updated my SK2 and all is well again. Thanks WindyT!

    I have a lot of posts, and a lot of comments, that need fixing. is there an easy way to update the database, without having to go in and do a lot of typing? has someone already put together an update query that i might be able to pilfer? <grin>

    no easy way I know of, but you could add a comment and then erase it. That seems to work. It’s low-tech and slow, but no need to know mySQL

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘After Upgrade to 2.x: Number of comments shows 0 when there’s plenty of comments’ is closed to new replies.