WordPress.org

Forums

After Upgrade to 2.8.2 I get a Redirect Loop (7 posts)

  1. Shimshon9
    Member
    Posted 5 years ago #

    I just upgraded from 2.8 to 2.8.1. I reactivated my plugins and now I get a Redirect Loop error when I try to access Admin.

    The site is working though!

    Any ideas?

    This is the error I am getting from firefox:

    Redirect Loop

    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

    The browser has stopped trying to retrieve the requested item. The site is redirecting the request in a way that will never complete.

    * Have you disabled or blocked cookies required by this site?
    * NOTE: If accepting the site's cookies does not resolve the problem, it is likely a server configuration issue and not your computer.

  2. esmi
    Forum Moderator
    Posted 5 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-related problems.

    - renaming the plugins folder via FTP

  3. Shimshon9
    Member
    Posted 5 years ago #

    The problem is that I cannot access my admin area. I will have to try your last suggestion. Is it possible to deactivate specific Plu ins via FTP?

  4. esmi
    Forum Moderator
    Posted 5 years ago #

    Yes - just rename the individual folders within wp-content/plugins.

  5. houseofzane
    Member
    Posted 5 years ago #

    I have the same problem with another wordpress site I'm running after the upgrade... I've tried everything. I've renamed the plugins folder, I've renamed the themes folder, I've went into my DB and checked the siteURL table, I've uploaded fresh files through a different client... EVERYTHING!

    For some reason it's always redirecting me to the login page and it's driving me insane. After I login, I can manually a URL like http://www.sitename.com/wp-admin/index.php, and I go straight to the dashboard.

    I can't think of what else it could be... this seems to be a very common problem with 2.8.2, and it's keeping me from upgrading my other sites.

    Any thoughts?

  6. houseofzane
    Member
    Posted 5 years ago #

    ok I just kinda did a hackjob fix to it... line 515 of wp-login.php had a crazy redirect command at the end, so I just changed it to value="wp-admin/index.php" ... now it takes me to the dashboard.

    Easy enough fix. Don't know how it got screwed up in the first place, though.

  7. bigfishweb
    Member
    Posted 5 years ago #

    Simply delete your cookies for the site, and it clears it up...

    Regards

Topic Closed

This topic has been closed to new replies.

About this Topic