WordPress.org

Support

Support » Plugins and Hacks » WordPress Popular Posts » [Resolved] After Upgrade – Says No Data :(

[Resolved] After Upgrade – Says No Data :(

Viewing 15 replies - 16 through 30 (of 39 total)
  • Thank you Hector!

    Plugin Author Hector Cabrera

    @hcabrera

    Hey guys, I can’t seem to be able to replicate the issue on my test enviroment – everything works for me. So, I’m reaching out for a little help from you.

    Is there any chance to get a copy of the following db tables: wp_posts, wp_postsmeta, wp_terms, wp_term_relationship, wp_term_taxonomy, wp_popularpostsdata and wp_popularpostsdatacache? The reason I’m asking this is that I’d like to replicate the problem using data generated by day-to-day use and hopefully understand why it happens in order to get a proper fix. I won’t be keeping your data nor share it with anyone, of course. I’m just interested in fixing the problem.

    If anyone is willing to provide the requested info, I’ll be really grateful. My e-mail is hcabrerab at gmail.

    Thanks in advance for your help!

    Hector; yes you are correct. It is singular “post”.

    @héctor Cabrera, it appears that the latest version of the plugin doesn’t insert the Ajax call in the header.

    This is why there is a problem collecting and displaying data.

    Plugin Author Hector Cabrera

    @hcabrera

    Hi dukeo, the updating part of the plugin has changed on 2.3.3. The ajax call isn’t really necessary anymore since the plugin can hook to the_content() call and know when a single post was viewed, so it can update to the BD. WPP actually worked like this in the past on early versions.

    It still can be enabled using the Ajaxify option on Settings > WordPress Popular Posts > Tools since it can be useful when using caching plugins such as WP Super Cache in order to avoid it caching the list of popular posts – these will be generated via Ajax instead.

    @héctor Cabrera the_content() is not called when pages are cached.

    Moreover, I have some custom pages on my blog that do not use the_content() since all the content of the page is hard-coded in the page template. (Maybe I’m not the only person who’s doing that)

    Plugin Author Hector Cabrera

    @hcabrera

    I’m aware of that, and that’s what the Ajaxify feature is for. When active, WPP hooks to wp_head instead and injects the Ajax call, updating the views count when is_single() returns true. Since you’re using a caching plugin, you should enable this option (and probably also clear the caching plugin’ cache one time after enabling the Ajaxify option).

    I have also had the same problem on my site, minutemenministries.org. I use it all over the site in different ways, and every instance that I have seen is giving me the same problem. Could you please fix it and release a new version asap?

    Plugin Author Hector Cabrera

    @hcabrera

    @bobbybosler: don’t worry, I’m already working on it. I posted a link to get the previous version of the plugin a few comments back, please use it to downgrade until a fix is ready.

    @all: already got the data I was asking for. Many thanks! I’m starting the tests now, will keep you informed. There’s no ETA though, so in the meantime please consider downgrading to v2.3.2 (link posted above).

    Ooops! I have downgraded to Version 2.3.1. I just fixed that, and downgraded to Version 2.3.2.

    Thanks Hector!

    Plugin Author Hector Cabrera

    @hcabrera

    Quick update:

    Found out what was wrong and -hopefully- fixed it. Just asked someone to try out the new version of the plugin and if everything’s alright then an official update will be issued shortly.

    I also took the opportunity to add a small change in the Stats section. I believe you all will like it 🙂

    You are great Hector, and we all love the plugin. Thanks for bearing with us all.

    Hector,
    I just tried 2.3.3, and unless I am doing something wrong, I am still experiencing the same problem. In Category(ies) ID(s): I only want to display category 225. I select to show post views only, and to display the top ten; however, only the top [most popular] post appears.

    When I downgraded to 2.3.2, I used the exact same settings and all was well.

    Mark

    Plugin Author Hector Cabrera

    @hcabrera

    Hey Mark, the update with the fix isn’t available yet. Version 2.3.3 on WordPress.org is still bugged, the current stable version is 2.3.2. Please use the latter instead.

    Oh, OK Hector.
    I will revert back to 2.3.2 again.

    Thank you!

Viewing 15 replies - 16 through 30 (of 39 total)
  • The topic ‘[Resolved] After Upgrade – Says No Data :(’ is closed to new replies.
Skip to toolbar