WordPress.org

Support

Support » Plugins and Hacks » Toolset Types » [Resolved] After upgrade, cannot view posts anymore

[Resolved] After upgrade, cannot view posts anymore

Viewing 12 replies - 1 through 12 (of 12 total)
  • Can you briefly describe the failure and let me know if you have other plugins installed that might affect this? for example, wpml.
    And have you updated those aswell?

    I did not install any recent plugins, but here is a list of my plugins.

    screenshot

    Whenever clicking view on one of my custom posts that previously worked I would get a page not found. I thought this might be a template issues, so i double checked my php file template was named single-[nameofpost].php and that was correct and went unchanged and was also working before the update. I then deleted that template and set the custom post to use a default template and it still was not showing up.

    NEXT I deleted my cookies and tested on another computer both results were still the same and displaying a page not found.

    THEN I proceeded to uninstall the plugin and even went to far as to delete ALL of my custom posts and taxonomies. I then reactivated everything and made a FRESH new post type and taxonomy, still same results.

    I finally fixed it by resetting my plugin folder…(so painful!)

    1. going into my ftp, navigating to /wp-content/ folder
    2. creating a folder called plugin-temp
    3. moving ALL plugins located in the plugin folder to the new plugin-temp folder
    4. the plugin folder was now empty
    5. logging into wp-admin of the site
    6. clicking plugins, and received many wordpress errors indicating the missing plugins
    7. finally went back to ftp, and moved all the plugins back into the normal plugin folder
    8. re-activated every plugin

    it now works again..for now! Still not sure what happened but I also lost all my custom posts.

    I think something is broken in 1.2. I had been using Types for a long time, for several previous versions. Upon upgrade, I began seeing exactly what others are noticing here.

    Nothing I could try to fix it worked (reinstalling, deleting all types and re-importing them). I kept getting 404 errors for both the slug url and the posts themselves.

    To help troubleshoot, I installed the “Rewrite Rules Inspector” plugin, which noted that there were a bunch of missing sources for the permalinks created by the Types plugin.

    Then I deactivated the Types plugin, downloaded the previous version of the plugin, and uploaded it. Upon reactivating, everything worked perfectly and “Rewrite Rules Inspector” showed that all the problems were gone.

    Please fix this!

    Hey guys – I am experiencing the same issue with V1.2 – 404 errors for Custom Post Types. Downgrading to 1.1.3.4 has resolved the issue.

    Hey @digicution,
    Where can i find the 1.1.3.4 version to download?
    Thanks!

    Hey @cristiano,

    All previous versions are available on the WordPress plugin repo. 1.1.3.4 is available here – http://downloads.wordpress.org/plugin/types.1.1.3.4.zip

    Hope this helps 🙂

    thanks!! 😉

    Still no update on this? I’d like to update to 1.2.

    Hi bstritesky,

    Please upgrade to latest version after taking a backup. Hope it will work.

    [ Signature moderated. ]

    I rolled back to 1.1.3.4 thinking that would fix this problem of getting ‘Page not found’. Seems related to options checked in settings for the CPT.

    Hi nancyeb01,

    Please confirm you had issues with Types 1.2.2.

    [ Signature moderated. ]

    Hi mbigul,
    I upgraded to 1.2.2, and the archive page permalinks now seem to be working again. Thanks!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] After upgrade, cannot view posts anymore’ is closed to new replies.
Skip to toolbar