Support » Plugin: RVM - Responsive Vector Maps » After updating to PHP 8.0.1 I cannot edit the maps

  • Resolved elisaskillisch

    (@elisaskillisch)


    Hello,

    I experienced a problem after updating the PHP version.

    When I try to edit the map I get a notification of a critical error. These are the details in the mail:

    Fehler-Details
    ==============
    Ein Fehler vom Typ E_ERROR wurde in der Zeile 52 der Datei /usr/local/www/apache24/noexec/budissa-bag.de/wp-content/plugins/responsive-vector-maps/includes/rvm_markers.php verursacht. Fehlermeldung: Uncaught TypeError: count(): Argument #1 ($var) must be of type Countable|array, bool given in /usr/local/www/apache24/noexec/budissa-bag.de/wp-content/plugins/responsive-vector-maps/includes/rvm_markers.php:52
    Stack trace:
    #0 /usr/local/www/apache24/noexec/budissa-bag.de/wp-content/plugins/responsive-vector-maps/includes/rvm_core.php(920): include_once()
    #1 /usr/local/www/apache24/noexec/budissa-bag.de/wp-admin/includes/template.php(1389): rvm_mb_function(Object(WP_Post), Array)
    #2 /usr/local/www/apache24/noexec/budissa-bag.de/wp-admin/edit-form-advanced.php(688): do_meta_boxes(Object(WP_Screen), ‘normal’, Object(WP_Post))
    #3 /usr/local/www/apache24/noexec/budissa-bag.de/wp-admin/post.php(206): require(‘/usr/local/www/…’)
    #4 {main}
    thrown

    Is there anything I can do to edit my maps again? Thank you very much.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.