Support » Plugin: Quiz And Survey Master - Best Quiz, Exam and Survey Plugin for WordPress » After updating to 5.0 can’t access admin anymore

  • Resolved johanna2patricia

    (@johanna2patricia)


    Hi,
    I updated the plugin to the 5.0 version. After doing that I couldn’t access my wp admin anymore. “Too many redirects”. I cleared the browser cache, bit that didn’t solve it.
    I renamed the plugin through ftp and now I have access to my admin again.
    What can I do to be able to use this plugin without losing access to my admin?

    Johanna

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hey @johanna2patricia

    Thank you for choosing to use this plugin and for your patience!

    I am sorry that you are experiencing this issue. So far, this is the only reported case of this issue. The plugin does not have any new redirects in this update. In fact, the plugin only has one at all and that has been in place for almost two years so it shouldn’t be anything that is affecting your site suddenly.

    If you try to activate the plugin, does it automatically crash your admin or only when you log back in? Can you check your error logs for anything recent? Usually, depending on WordPress setup, you may have a debug log in /wp-content or you may have an error log in your server admin such as in cPanel.

    Thread Starter johanna2patricia

    (@johanna2patricia)

    Hi Frank,
    I renamed the pluginfolder to “quiz-master-next2” and then I could log in again.
    Fortunately I had the backup files, so I uploaded the 4.7.10 version. That works alright.
    When I removed the 4.7.10 folder and renamed the quiz-master-next2 folder to quiz-master-next again the same thing happened.
    I checked on another site of mine and there the update to 5.0 went well, so it is related to this one site of mine: https://www.patriciakaas.nl/blog/
    I looked in the error logs in my directadmin, but there isn’t anything.
    In the usage logs however I see this line:

    IP number- - [28/Mar/2017:00:02:22 +0200] "GET /blog/wp-admin/index.php?page=qsm_about HTTP/1.1" 302 704 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36"

    And then like 50 times or so. That isn’t right of course.
    So what can I do?
    I have now one activated 4.7.10 version and one deactivated 5.0 version.
    Should I remove the folder “quiz-master-next2”?
    But how to get that 5.0 update?
    Or should I put back a backup of the database and try to update to 5.0 again?

    Johanna

    • This reply was modified 3 years, 11 months ago by johanna2patricia.
    • This reply was modified 3 years, 11 months ago by t-p.
    Thread Starter johanna2patricia

    (@johanna2patricia)

    Hi Frank,
    I renamed the plugin folder to “quiz-master-next2” and then I could login again.
    I uploaded the 4.7.10 version with ftp and then the plugin worked well again.
    I looked in my error logs in my directadmin, but there is nothing there.
    In the usage logs however I see this line:

    IP number- - [28/Mar/2017:00:02:22 +0200] "GET /blog/wp-admin/index.php?page=qsm_about HTTP/1.1" 302 704 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36"

    And then like 50 times. That isn’t good of course.
    But what can I do to get the 5.0 version? Should I delete the “quiz-master-next2” folder? And then try it again?
    Or should I put back a backup of the database? And then try again?

    Johanna

    Thread Starter johanna2patricia

    (@johanna2patricia)

    Hi Frank,
    Ok I solved it. I deleted the deactivated 5.0 version, swept the database with Sweep.
    I saw you had a 5.01 update, so I updated the 4.7.10 version to 5.01 and that worked!
    All good now.

    Johanna

    I just updeated to version 5.0.4 and had the same problem. Once I deactated via FTP, I could log in again.

    Thread Starter johanna2patricia

    (@johanna2patricia)

    I had the same on some of my sites again.
    Even after I flushed the Redis cache I couldn’t update.
    I think it is a mess with this plugin.
    Stil no possibility to embed video’s either.
    And when you write support you never get an answer.
    I disabled the plugin on all my sites.
    I hope one day this will be solved.
    For now I am searching another quiz plugin. If somebody has a suggestion let me know please.

    Johanna

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘After updating to 5.0 can’t access admin anymore’ is closed to new replies.