WP eCommerce
After Updating to 3.8.14 Category pages don't work (5 posts)

  1. dynamicdesign11
    Posted 1 year ago #

    I just updated to 3.8.14 from 3.7.8. While the product pages are working, the category pages are blank. I am using the most recent version of WordPress and the theme I am using worked fine with the older version of WP e-commerce.

    What can be wrong?


  2. Justin Sainton
    Plugin Author

    Posted 1 year ago #

    Hi dynamicdesign11,

    I'd love to take a look at this for you, this is one of the older migrations I've heard of and I'd love to make sure we're handling it properly. If you're able to email me credentials to access your WordPress admin area, I'd be more than happy to take a look. My email is justinsainton at gmail dot com.


  3. dynamicdesign11
    Posted 1 year ago #


    I sent you the information - let me know if you can find a solution.

    Thanks for your help!

  4. dynamicwebs.com.au
    Posted 1 year ago #


    I have the same problem (I think). Was this issue fixed?

    A customer started reporting strange problems with version 3.7.8 (eg when you try to click such as to enter the title, we get a strange perpetual "loading" box and the screen greys out) so I upgraded to and then to 3.8.14. Everything seemed fine and the client loved how much easier it was to use the system... until...

    Using 1 category as an example, which has 10 product in it, none show up on the category page. When I added a new "test" product, then all of the products would reappear. Delete the test product, and all the other products would disappear.

    Now, pretty much the opposite happens - add 1 product and it might appear - just 1 product on the category page. Add 2 products and they might all disappear again. Assign the product to another category and suddenly all those category products disappear too.

    I've tried different versions of wp e-commerce, turning off plugins inc gold cart, adjusting presentation settings, moving theme files, flushing theme cache, etc.

    I'm totally stuck and I've spent quite a lot of time on this. Should I start a new support thread so that I do not hijack this one any further?


  5. dynamicwebs.com.au
    Posted 1 year ago #

    My error may be related to the Atahualpa theme. Atahualpa and wp e-commerce do not play well together. However as with dynamicdesign11, the site works fine until wp e-commerce was upgraded.

    The problem in my case - excerpts. Atahualpa is a theme that uses excerpts for the blog category pages. Since wp e-commerce also uses blog category pages for product categories, the shopping cart inherits any excerpt settings from the theme.

    For me the fix was to set the theme to display the "full post" (ie product) instead of the excerpt.

    If your theme uses excerpts in a similar fashion, might be worth looking into.


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP eCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.