WordPress.org

Ready to get started?Download WordPress

Forums

myCRED
[resolved] After updating to 1.1 (23 posts)

  1. MavinSadow
    Member
    Posted 1 year ago #

    After updating to 1.1 I get the error below, I can not login to even turn the plugin off.

    Fatal error: Class 'myCRED_Hooks' not found in /home/axishq/public_html/main/wp-content/plugins/mycred/modules/mycred-module-plugins.php on line 821

    http://8thexpeditionaryfleet.org/main/

    http://wordpress.org/extend/plugins/mycred/

  2. Gabriel
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Mavin

    If you login to your site though FTP and move the mycred folder out of the plugins directory and into the wp-content directory you should be able to access your site at least.

    Once your in, you can then move the plugin back to the plugins folder. WP will disable mycred when it not longer finds it. Can I ask from what version you updated?

    Also, do you have WP_DEBUG set to true in your wp-config.php file?

  3. Gabriel
    Member
    Plugin Author

    Posted 1 year ago #

    I see I miss-spelled the name as it supposed to be just myCRED_Hook and not myCRED_Hooks. If you remove the "s" in the name it should work again.

  4. Blue-Alien Pink-Brain
    Member
    Posted 1 year ago #

    Hi,

    I got this error message after activating the plugin the first time:

    Fatal error: Class 'myCRED_Hook' not found in /home/username/public_html/wp-content/plugins/mycred/plugins/mycred-hook-bbPress.php on line 58

    Do this plugin not work with bbpress?

    Please advise.

  5. Gabriel
    Member
    Plugin Author

    Posted 1 year ago #

    Hey.

    That is very strange. Please delete the version you have and re-download

  6. Blue-Alien Pink-Brain
    Member
    Posted 1 year ago #

    Problem solved, Thank you Gabriel.

  7. Gabriel
    Member
    Plugin Author

    Posted 1 year ago #

    Thank you for letting me know! Enjoy!

  8. Blue-Alien Pink-Brain
    Member
    Posted 1 year ago #

    Hi Gabriel,

    Been playing around with myCred, loss of words... - Awesome!

    Just a question, the integration with Buddy gifts, I see that the buddy gifts plugin hasn't been updated for over two years -doesn't work on my multisite,

    So I've got buddy gifts rebirth installed, but I'm getting this error with that plugin: Warning: Missing argument 2 for wpdb::prepare() - plugins/bp-gifts-rebirth/includes/bp-gifts-classes.php on line 291 and defined in...

    I take it 'rebirth' is not the same plugin as referred to with the integration?

    Is there any other plugin option for gifts with myCred?

    Again, great work with myCred!

  9. Gabriel
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Blue Alien

    Yeah BuddyPress gifts is an old plugin and I included it in the BuddyPress add-on as at the time of creating myCRED a lot of clients used it so I thought I trow it in as well.

    The error you are referring to is in relation to the plugin you installed. It's not one I have ever used so it's not something that myCRED has a built in support for. But that does not mean you can not add your own link between the two. As long as the plugin is "pluggable" meaning we can hook in some fashion we can connect the two.

  10. Blue-Alien Pink-Brain
    Member
    Posted 1 year ago #

    Hi Gabriel,

    It would be great having this feature as it would greatly boost the interactions between members, unfortunately I'm not good with coding plugins, I read up about 'Buddypress Gifts Rebirth' this morning, it's not compatible with Buddypress 1.8.

    There is an updated version called 'Buddypress Member Gifts' apparently coming out soon? Should have been updated to work with Buddypress 1.8 mid September according to the author, but it's not yet, and no response on the Forums...

    It would be great having this feature as a myCred feature, I'm astonished there isn't more options out there which we can use to create a hook...

    Love your work though...

    Blue Alien (Of Probing)

  11. Gabriel
    Member
    Plugin Author

    Posted 1 year ago #

    You can always request support for third-party plugins though the myCRED website. If the plugin can be hooked I can always try and provide you with a custom hook to use. Maybe once there is a plugin out there that can handle gifts for BuddyPress we can look at adding into the BuddyPress add-on.

  12. Blue-Alien Pink-Brain
    Member
    Posted 1 year ago #

    Hi Gabriel,

    I guess I'll have to wait and see if the Buddypress 1.8 compatible version comes out, and then request support.

    Truth is I'm not sure if the Plugin will do What I need.

    I'm sure it will have some kind of gift store where users buy gifts for others, but I also need a Gift Basket created in each users Profile where they can 'Store' and display all gifts received and who from. Hopefully then with myCred, users can either buy gifts with points, or have an option to charge cash for gift purchases.

    Not sure how you feel about this feature, but if you have the time, maybe create your own gift feature included in a Pro version of myCred, or a Premium Add-on. I'm buying!

    Blue Alien (We don't abduct blonds! That's a myth...)

  13. Gabriel
    Member
    Plugin Author

    Posted 1 year ago #

    Hey.

    If a "store" plugin comes out offering purchases of gifts I would be more then happy to help you let users buy items in that store using points but I a "Gift" plugin is not something that would fall under "Points Management" and I am busy as it is with myCRED to create a new plugin.

  14. Blue-Alien Pink-Brain
    Member
    Posted 1 year ago #

    No Problem,

    Just a suggestion, hopefully one will arise...

    Great work with myCred.

  15. Blue-Alien Pink-Brain
    Member
    Posted 1 year ago #

    Hi Gabriel,

    When a user transfer points to another google gives the following popup, 'The page at http://www.blogname.com says:
    Communications error. Please try again later.'

    Then after clicking the 'OK' button, the page refreshes and the points are transferred.

    How can I fix this?

    Also the Email notifications doesn't send emails, I set up the default, and created two notifications, set the instances, and entered the default email addresses, tried both the admin@blogname.com email, and a gmail account.

    Please advise.

    FYI, I found a plugin called Feeligo for the gifts plugin, it does everything I need, but having a few issues there as well :(

    Blue Alien out...

  16. Blue-Alien Pink-Brain
    Member
    Posted 1 year ago #

    Hi Gabriel,

    Sorry for all the posts,

    When Transferring points, the user has to enter the username of the person they want to transfer to, is there a way to enter the name-field (I'm using Buddypress extended profile fields)?

    Also, is there a way to show the Rank and Rank image on the members' directory list?

    I see that as admin I can view all member's Rank and Image shown on their profile page, but as a subscriber, I cannot, only the points. Please advise.

    FYI, Got Feeligo to work, it's a bit over the top to be honest...

  17. Blue-Alien Pink-Brain
    Member
    Posted 1 year ago #

    Hi Gabriel, just found that all the Notices for transferred points, where emailed to the - 'Reply to' email address.

  18. jfsantacreu
    Member
    Posted 1 year ago #

    Hi Gabriel.
    After updating to V 1.3.1 I can´t enter anymore in our site: http://www.freehotels.ws
    I´ve removed the myCRED folder using FTP access but the problem still there...
    Any idea ?
    Thanks
    JF

  19. Gabriel
    Member
    Plugin Author

    Posted 1 year ago #

    @Blue-Alien Pink-Brain

    Right now the Transfer add-on only supports user_login searches. I will look at improving this in future updates.

  20. Blue-Alien Pink-Brain
    Member
    Posted 1 year ago #

    Hi Gabriel,

    I've turned Email Notices and notices off for now, I'm fine without it for now.

    On a different note, when creating a Archive URL for the Rank page, it's create at /blog/ranks/ which makes it a post. But there is no link to previous or next post from this page, did I do something wrong?

    Please advise.

  21. Blue-Alien Pink-Brain
    Member
    Posted 1 year ago #

    @Gabriel

    Also, is there a way to show the Rank and Rank image on the members' directory list?

    I see that as admin I can view all member's Rank and Image shown on their profile page, but as a subscriber, I cannot, only the points. Please advise.

    Blue-Alien...

  22. Gabriel
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Blue Alien.

    You can insert a rank title or logo or any other part anywhere you want. Especially when it comes to your theme which allows you full control of how things work and look.

    Locate the template file that effects the page where you want to include the logo and use the mycred_get_rank_logo (as an example) to insert a rank logo.

    Regarding the URL, sounds like your Permalink settings is /blog/%postname%/, check your permalink setup. You can also check your Rank settings on the myCRED > Settings page.

    Remember that Ranks are just normal posts (custom post types) so when it comes to displaying them or building archives for them they work and behave just like any other posts. I have a more in depth tutorial on how you can add rank archives and customizations around your WordPress website that might be off help.

  23. Blue-Alien Pink-Brain
    Member
    Posted 1 year ago #

    OMW, Feel like I don't even know the basics anymore.

    Changed the Permalinks to Numeric, then the navigation was right, but the Ranks page only showed the Featured image instead of the Ranks, or what I would like to call sub-posts, expect if I'm missing how it is supposed to work.

    Anyway, then changed it to default, and now I get 404 Page not found, changed it back to Numeric, same thing, updated it again, still same problem?

    I'm taking a break now... Book marked your Tutorial, will check it out in a bit.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.