Support » Plugin: Swift Performance Lite » After Updating My posts, It doesn’t appear until i clear cache

  • Thanks a lot for this great plugin. I will keep on announcing that this is the best caching plugin.

    Just so you know if you don’t help me fix my problem, I will still be grateful you made this plugin.

    Well I have a little problem with the plugin. When I post a new content on my blog it doesn’t show on fronted until I manually clear the cache.

    Well I went through you documentations. So I think you should know my existing settings (regarding my problem).

    1. Caching Mode: Disk Cache with Rewrites.
    2. Cache Expiry Mode: Action Based.
    3. AJAX Cache Expiry Time: 1440.
    4. I use cloudflare CDN (and its integrated into Swift)

    I was informed that since I am using the above settings, I shouldn’t be having this issue.

    Can you please help me solve this.

    Thanks once more

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor Fred

    (@fredawd)

    Thank you for your kind words.

    You may use Clear Cache on Update Post by Page and/or Clear Cache on Update Post by URL (settings->Caching->General) to set pages which should be cleared automatically after you publish/update post.

    My blog is a news blog. DO I need to start putting all the thousands of url.

    Also my posts appears on both home page and archives (tag and category), so which page am I suppose to chose.

    I don’t have a custom home page so home page is my blog posts.

    Please any help on how to fix this. My url is https://allschool.com.ng/.

    Please help

    Plugin Contributor Fred

    (@fredawd)

    Set your blogpage in Clear Cache on Update Post by Page. Tag & Category pages should cleared and rebuild automatically.

    It this specific case, best solution would be to use Lazyload elements for the sidebar widgets on all pages – It is an Ajaxify feature designed to speed up page loading times and decrease traffic to your customers and users by only loading the content in view. It can be useful for elements which can’t be cached and should be loaded dynamically, like most popular posts, recent comments latest posts, etc.. unfortunately, this feature is available only in Pro version.

    Also, I see some errors on frontend of your site (missing icons). Fastest solution is to disable merge Styles or find the responsible, conflicting style and exclude it from merge.

    diraph

    (@diraph)

    Thanks

    Please how can I identify the script responsible for the missing icons

    Plugin Contributor Fred

    (@fredawd)

    You may try to set: /css/font-awesome.min.css
    in Settings->Optimization->Styles: Exclude Styles

    diraph

    (@diraph)

    I deleted that style from my theme. and am using that of CDN. Could that be the problem?

    Sorry I am re-opening this issue just that I want to be cleared more.

    You said

    Set your blogpage in Clear Cache on Update Post by Page. Tag & Category pages should cleared and rebuild automatically.

    In the case where my latest post are beening displayed on my primary url (allschool.com.ng), should I also set that as my Clear Cache on Update Post by URL?

    If yes, does that means that my website will be cleared every time I make a single post? If yes, won’t that make the website a bit slow?

    Thanks

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.