WordPress.org

Support

Support » Plugins and Hacks » After updating I'm getting Fatal Error

After updating I'm getting Fatal Error

Viewing 15 replies - 1 through 15 (of 23 total)
  • I have also a problem after update some plugins on wordpress 3.5.1 cannot login into my backend only a blanck screen appears

    Plugin Author Frederick Townes

    @fredericktownes

    What are the errors in your web server error logs?

    I tried to upgrade too and it’s brought the entire site down, including the admin pages. I have no idea how to get my site back up and running.

    The php.error.log states:

    [05-Feb-2013 18:32:45 UTC] WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘status timestamp <= 1265481164 and id not in (select redirect_id from wp_wbz404_’ at line 1 for query select id from wp_wbz404_redirects where status = 2 status timestamp <= 1265481164 and id not in (select redirect_id from wp_wbz404_logs) made by do_action_ref_array, call_user_func_array, wbz404_cleaningCron, W3_Db->query
    [05-Feb-2013 18:48:51 UTC] PHP Fatal error: Cannot redeclare class W3_ObjectCache in /mnt/stor1-wc1-dfw1/380423/529199/www.ptolemy.co.uk/web/content/wp-content/plugins/w3-total-cache/lib/W3/ObjectCache.php on line 9

    I too get a fatal error when attempting to activate the latest release (0.9.2.6).

    The error appears to come from the script attempting to write outside of the wordpress directory. I’ve included the error below:

    Warning: realpath() [function.realpath]: SAFE MODE Restriction in effect. The script whose uid/gid is 5780/40307 is not allowed to access /data1/information/www/home_pages/departments owned by uid/gid 0/30000 in /data1/information/www/home_pages/departments/today/wp-content/plugins/w3-total-cache/inc/define.php on line 711
    /data1/information/www/home_pages/departments/today/wp-content/w3tc-config/master.php could not be created, please run following command:
    chmod 777 /data1/information/www/home_pages/departments/today/wp-content/w3tc-config

    It should be noted that 0.9.2.5 activates and operates fine under current server conditions.

    I’m getting this as well. Thankfully, my site still seems to be working. Would appreciate information on how to resolve this issue.

    I was able to get my website and wp-admin back by deleting the plugin, and the three php files in the root of wp-content related to w3 total cache. I will not be using the plugin again. I hope everyone else can resolve their issues!

    Plugin Author Frederick Townes

    @fredericktownes

    @geekles Can you try commenting out line 711 in define.php . Should look like // $document_root = realpath($document_root). It could be that the plugin cannot handle your sever variables (filepaths etc) properly. Latest version tries to figure out proper paths on a number of different server setups. Some might be missing. Either way, submitting a bug submission form would be appreciated.

    @alecmce, sorry to hear that, unfortunately caching is a “low level” problem, most plugins have far less to deal with. If you would contribute by submitting a bug submission form or sending me an email it would be helpful.

    @frederick I appreciate it’s hard. I don’t envy you trying to write a plugin for such a complex ecosystem. I just can’t trust the plugin now, so I’m going to find another solution. I don’t have much to add in a bug submission other than the error that I printed out above, and that I’m using 3.5.1. Good luck ironing out all these issues for your other users!

    @frederick I’ll give this a go tomorrow. Thanks for your response.

    I got lucky…the update got stuck trying to unpack then I found these posts of the problems you guys are having! I’m not that technical and don’t what to mess around with the php – if something goes down, I’ won’t be able to fix it. I’ll see how it goes but might have to back out too it it gets to complicated . Good luck Fredrick!

    I have the same problem on TWO sites (BLANK PAGE AFTER LOGIN) and I’d like to receive a quick and dirty solution.
    Can I just delete it from my server and that’s it? I would like to uninstall it so that I can access my backend again…

    How can I do this?

    Thanks in advance!!!
    K.

    Hello All some have previously posted that it is best to uninstalled the old plugin delete all the plugins files from your sever via FTP and install the new upgrade. This has worked for all who have reported issues like yourself.

    Try and see if this works.

    Kind regards

    I was in the middle of activating (it had been deactivated) the W3 total cache when I received this message
    Fatal error: Call to undefined function wp_cache_debug() in /home/content/68/8619968/html/wp-content/plugins/wp-super-cache/wp-cache.php on line 2483

    Now I can’t get into my site at all. If I could, I would delete it but nothing. Any help or ideas?

    W3C Total Cache and WP Super Cache are different plugins; it seems to me that you’re trying to run two cache managers. If you can login into your site, go to the Plugins tab and disable WP Super Cache, then enable W3C Total Cache.

    If you can’t login to your site, use your hosting panel to gain access, go to wp-content/plugins and rename the WP Super Cache folder to disable it, and then try to login to your admin panel. At this point WP Super Cache should be disabled, now you can try to activate W3C Total Cache.

    Hope that helps.

    Hello @kdaukas

    You might want to try the following….this list I have compiled into a post in my website from all the people here who have reported solutions……

    Removing W3 Total Cache Completely

    1 ) Remove the following files in ‘wp-content’ folder.
    – advanced-cache.php
    – db.php
    – object-cache.php

    2 ) Remove the folder named w3-total-cache that may be residing in ‘wp-content/plugins’ folder.

    3 ) Remove the line define(‘WP_CACHE’, true); in your wp-config.php file.

    4 ) Remove /wp-content/w3tc/ dir

    5 ) Remove /wp-content/w3-total-cache-config.php file

    For W3 Total Cache 0.9.2.6/7 add also the following steps:

    6 ) Remove /wp-content/w3tc-config/ dir

    7 ) Remove /wp-content/cache/ dir

    8 ) Delete all the entries in your .htaccess except the default entries made by wordpress……..

    I hope this helps you..

    Kind regards

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘After updating I'm getting Fatal Error’ is closed to new replies.