Support » Plugin: WooCommerce 3D Secure (Bankart) Payment Gateway » After updating from 1.1 to the 1.2 version it doesn’t work.

  • Hi,

    We are working with NLB bank from Macedonia.
    After updating the plugin from 1.1 to the 1.2 version, when you click proceed to checkout it doesn’t transfer you to the payment link where you can fill your card details it said something like bankart payment Error.
    I instantly made a backup to my site to restore the old version so we wont lose any payments, so you wont see the problem if you try it.
    Can you please tell me what to do should i update it or not ?

    Thanks in advance.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 16 through 24 (of 24 total)
  • Plugin Author geca

    (@geca)

    @icime85 I’ve prepared a new version of the plugin that should hopefully provide more insight into your problems.

    Here’s the step-by-step procedure on what you should do:

    1. Uninstall existing plugin (make sure to make backups of your CGNs if needed)
    2. Remove any records from the wp_options table with a value of woocommerce_bankart_settings
    3. Fetch the new plugin from here: https://plugins.trac.wordpress.org/browser/woo-3d-secure-bankart-payment-gateway/branches/1.2.1/
    4. Add CGNs to cgn/production and/or cgn/testing dirs
    5. Install the plugin and make sure wp-admin/admin.php?page=wc-settings&tab=checkout&section=bankart shows that resources(s) is/are available
    6. Make a test purchase. You should see something along the following lines in your log:

      
      10-19-2019 @ 20:01:37 - Processing payment for order_id=25 ...
      10-19-2019 @ 20:01:37 - POST-ing to Bankart: responseURL=https://ba6f9da4.ngrok.io/wc-api/bankart_callback, amt=407.25, action=4, trackid=25 ...
      10-19-2019 @ 20:02:06 - Received POST request from gateway: Array
      (
          [paymentid] => 7529364592192920
          [result] => NOT APPROVED
          [auth] => 000000
          [ref] => 929222801155
          [tranid] => 173943002292920
          [postdate] => 1020
          [trackid] => 25
          [responsecode] => 87
          [cvv2response] => D
          [eci] => 7
      )
      
      10-19-2019 @ 20:02:06 - Processing Bankart Purchase Response ...
      

    If your log output differs from the one above, test the plugin on a fresh WP installation, preferably in a different environment you’re using currently, and let me know how it goes.

    @geca hi, sory about late reply. I did all steps in your step by step instructions but problem is still there. Still having same problem, purchase goes through but after redirecting back to the shop I get blank screen. No errors in logs.
    In bankart log all I get is this:

    10-20-2019 @ 09:38:35 - Processing payment for order_id=24939 ...
    10-20-2019 @ 09:38:35 - POST-ing to Bankart: responseURL=https://mobimania.si/wc-api/bankart_callback, amt=0.01, action=4, trackid=24939 ...
    10-20-2019 @ 09:39:10 - Received GET request from gateway: 
    10-20-2019 @ 09:39:28 - Received GET request from gateway: 

    I think problem is that plugin doesnt get payment_id for redirecting back to the shop. Is there an option to redirect after purchase back to shops home page or any other page?

    Hi, can you tell me please, how Can I fix this error ( Payment error: Unexpected response from Bankart: )

    This is the backend plugin setting link:
    https://prnt.sc/qahlbw
    https://prnt.sc/qahlk4

    And this is the website where I’m trying to used this plugin:
    https://lip-satler.si/kategorija-izdelka/zibelke/

    @foodforce1 are you there?

    @geca are you there?

    @icime85 are you there?

    @adil143 try to replace .cng file with new from bankart

    @icime85 Thank you so much for your reply Sir, can you explain to me the complete process, because, I don’t know how to do that, and I don’t have an old version plugin.

    can you make a check this message please:
    Hi, can you tell me please, how Can I fix this error ( Payment error: Unexpected response from Bankart: )

    This is the backend plugin setting link:
    https://prnt.sc/qahlbw
    https://prnt.sc/qahlk4

    and Now, I’ve deactivated the plugin………… Please help me to fix this issue.

    Plugin Author geca

    (@geca)

    Hi @adil143, sorry for a bit of delay (and thanks @icime85 for providing support). If you’re still struggling with the plugin, here are two more things you can try:

    1. Ensure you’re using pretty permalinks.

    2. Try the plugin in isolation, inside a fresh WP install without any additional plugins. If it works, maybe there’s a clash with other plugin(s).

Viewing 9 replies - 16 through 24 (of 24 total)
  • The topic ‘After updating from 1.1 to the 1.2 version it doesn’t work.’ is closed to new replies.