WordPress.org

Support

Support » Plugins and Hacks » NextGEN Gallery - WordPress Gallery Plugin » [Resolved] After Update Widget Won't Work

[Resolved] After Update Widget Won't Work

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author photocrati

    @photocrati

    @roxyjo – Have you tried re-saving the widgets and/or re-inserting them into their widget areas?

    – Cais.

    I am having the same problem. I went through and resaved the widget settings for the sidebar widget, checked the settings for NextGEN slideshows and even checked the gallery that is linked to the slideshows.

    I also cleared my browser cache and refreshed.

    Still getting a spinning grey shade loader circle.

    Is this version of NextGEN slideshow not compatible with the NextGen upgrade?
    http://www.secondchanceaihadogs.com/forums/forum/aiha-dog/
    Thanks, Matoca

    Plugin Author photocrati

    @photocrati

    @matoca – It would be best if you started your own topic as there is most likely a difference between your two sites that could affect this issue.

    Thanks!

    – Cais.

    Hmm, Ok? What is different between our two problems? NextGEN Slideshow widget doesn’t work. That seems to be the crux of the problem. It worked before the upgrade and now it doesn’t.

    I really don’t like to pollute the troubleshooting forum with different posts covering the same problem and that is why I posted under this one.

    my best, Matoca

    @photocrati
    Yes, I have tried resaving just about anything that I can think of, including the Galleries, widgets, permalinks, resetting the options etc…
    The widgets seem to work OK if I choose “recently added” rather than “random”
    —————–
    The widget settings that do not work are:
    Show: 1 Original Images
    Random
    Width x Height: 700 X 150
    Select: Only which are listed
    Gallery ID: 7

    Plugin Author photocrati

    @photocrati

    @roxyjo – Interestingly enough there are now three near identical issues with those settings …

    … and unfortunately there does seem to be some sort of intermittent issue when the “random” option is chosen we were not aware of.

    @matoca – Thank you for starting your own topic, but to answer you question of why, it appears you are using the flash version of the slideshow and the OP is not. That makes the issues different. Please, lets continue with your issue in the topic you started.

    Thanks!

    – Cais.

    No, I specifically have Flash off. Under Gallery Settings>Basic Slideshow>Enable Flash Slideshow>NO. That has not changed since I started this slideshow last year. I definitely wanted to use HTML5 because I have a responsive site.

    RoxyJo, where do you set the Random? I can’t find that setting. I feel like I am checking multiple settings in my dashboard trying to resolve this, but this one I have not seen.

    I am getting pretty frustrated and now I am on two different topics.
    Matoca

    @matoca
    The random setting is in the NextGen Widget itself. 🙂

    Same problem in NextGen widget as RoxyJo and getting “no images were found” with following settings

    The widget settings that do not work are:
    Show: 1 Original Images
    Random
    Width x Height: 400 X 300
    Select: Only which are listed
    Gallery ID: 1

    Galleries checked. Widget works when set to “All galleries” (even with random set) but I need to work with specific gallery ID.

    Hope this newly introduced bug can be fixed soon.

    Plugin Author photocrati

    @photocrati

    @matoca – “I am getting pretty frustrated and now I am on two different topics.” That is yet another reason we recommend you create your own topic …

    @robf – As suggested earlier, it is best to create your own topic to deal with the issue on your site.

    All – The more people that pile onto a topic the less useful the topic becomes, especially to the OP. Please keep that in mind.

    Thanks!

    – Cais.

    Yes. Random seems to be a problem. I don’t know if you’ve seen my badly titled (I couldn’t edit it) post here

    I think I found the file responsible but I have no idea why, or how the substitution of some lines of code from the previous version cures it.

    I think Matoca is frustrated by the problem, and also doesn’t like having to be on another topic. I haven’t found the other topics. The problem appears to be the same for all of us. Setting random and a specific listed gallery in the widget causes the error message that no image can be found, and setting it to any gallery starts it working again.

    Starting new topics on the same or similar topic is only useful if there are links to those topics. You have no idea how frustrating and difficult it is searching for solutions; particularly when you often find promising looking solutions that dead end in ‘topic closed’. Problems evolve and interact. It helps US if close variations on a problem are on the same thread.

    Ok, I am posting in disguise, I have my Groucho glasses on (with nose and mustache.) This is NOT me.

    So I just did some experimenting after reading @digbymaass Random post. I never use the Flash setting (in Gallery Settings), but rather use the HTML5 setting (Flash set to No.) (That is why I couldn’t find the Random setting!) But for giggles I did set slideshow to Flash and Random in the Gallery Settings. The only setting I changed was Stretch Image=False.

    I also added another slideshow in my footer, besides the sidebar, just for reference and set that to another gallery, not the same one. This one I took the default size.

    Interesting, now they both play, but some photos are obviously being stretched. How can I tell this is Flash? If you right click any video and you see:
    Settings
    Global Settings
    About Adobe Flash (version #)
    You are using Flash playback.

    If you are not using Flash and you right click over the (my not-loading) HTML5 slideshow you see the standard browser menu of items such as Back, Forward, Reload etc.

    So it is clear that Flash playback IS WORKING for me, but not the HTML5 playback. Before I updated NextGEN plugin the HTML5 slideshow was working. I don’t want to use Flash, half of my moderators view the website via phone or tablet and this essentially doesn’t work on those devices.
    http://www.secondchanceaihadogs.com/forums/forum/aiha-dog/

    Now my conjecture. Bluehost has been attempting to get users to update their PHP versions for their hosting accounts. I did this quite a while back to Fast PHP ver 5.4.30. However, some plugins available on WordPress.org still need PHP ver 5.2. Bluehost wants to abandon supporting PHP 5.2. The last time they tried to do this, all my WP blogs went down for over 12 hours. This caused each WordPress blog to have the White Screen of Death. Is it possible that this upgrade for NextGEN slideshows requires PHP ver 5.2 to display HTML5? Do you know what your host requires for PHP version?

    So back to my own topic. Hope this helped a little?
    my best, groucho

    @photocrati my problem is identical to original poster’s so why complicate matters by asking me to post a separate thread?! As digbymaass says – Problems evolve and interact. It helps US if close variations on a problem are on the same thread.

    Please focus on diagnosing the actual problem

    My entire NextGEN broke today.

    Now, I’m not sure if it was NextGEN’s update or the JetPack UPdate.

    I reloaded both of the older plug-ins for JetPack and NextGEN but nothing.

    I replaced only the new JetPack and then the new NextGEN but nothing. I’ve tried every combination I can but nothing. I was using the masonry galleries.

    Now my all of galleries are screwed and will not work.

    The last time NextGen broke it was down for four months before it started working again. How long will it be this time?

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Resolved] After Update Widget Won't Work’ is closed to new replies.
Skip to toolbar