Support » Plugin: WooCommerce » After Update to WP 5.7 WooCommerce Categories PAges do not show the page numbers

  • Resolved kraeMit

    (@kraemit)


    Hi,

    WP5.7
    DIVI theme 4.9.2
    WooCommerce 5.0 and 5.1

    After updating to WP 5.7 I can’t access all products relating to a sub category, means e.g. I have 16 products in a product category, if I view this category the correct number is count (‘Showing all 16 results’ on the top), but only 12 products are shown and the page numbering o the bottom ist lost.

    Example URL : https://tinyurl.com/v6bp9zsn

    Edit: Found another category where it works … I didn’t change categories for months!

    Edit 2: This behaviour is indifferent, sometimes kust the 12 products are shown one the page, sometimes not all products are show. Very mysterious. :-/

    Please advice how to track this down.

    Thanks for reading and a tip!

    Best Regards!
    kraeMit

    • This topic was modified 2 months, 3 weeks ago by kraeMit.
    • This topic was modified 2 months, 3 weeks ago by kraeMit.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support gabrielfuentes

    (@gabrielfuentes)

    Hi there 👋

    This kind of problem is usually caused by a conflict with your theme or with another plugin.
     
    The best way to determine this is to:

    • Temporarily switch your theme to Storefront
    • Disable all plugins except for WooCommerce
    • Repeat the action that is causing the problem

    If you’re not seeing the same problem after completing the conflict test, then you know the problem was with the plugins and/or theme you deactivated. To figure out which plugin is causing the problem, reactivate your other plugins one by one, testing after each, until you find the one causing conflict. You can find a more detailed explanation on how to do a conflict test here.

    Before you start

    1. First, please make sure you have a good backup in place of your full site and database. Most hosting companies have this included in the subscription, but you could also consider using a service like Jetpack. If something goes wrong, it’s nice to know that you can restore your site.
    2. Second, I would suggest installing a plugin called Health Check & Troubleshooting. This is a plugin developed by the WordPress community and it allows you to disable plugins without affecting your current site visitors.
    Thread Starter kraeMit

    (@kraemit)

    @gabrielfuentes : Thanks you very much for your fast & detailed answer!!

    I’m a little afraid to kill data in my installation, if I switch the theme. But I will update my testsystem and will check again.
    I’m using a ot of plugins, so htis might be the problem source :-/

    I fideled around yesterday and found out, that creating a new category will fix this for several categiries, but not for all. This is no solution, but will help a bit.

    Thanks for the tip with StoreFront and Health Check & Troubleshooting, I will continue as advices.

    Thread Starter kraeMit

    (@kraemit)

    Update: By switching all plugins off and on I found out, that one of my most used plugins ‘NextGEN Gallery’ v3.9.0 causes all this failures. This is reproductable.

    All categories and tags in WooCommerce work as it’s best! 🙂 I’m sorry, I should have checked the plugins before, but had a little panic 😉

    That’s hard, because you just can’t exchange it : all pictures and galleries are out then. :-/

    THANKS for this excellent support!!

    • This reply was modified 2 months, 3 weeks ago by kraeMit.
    Plugin Support gabrielfuentes

    (@gabrielfuentes)

    Thank you @kraemit! Happy to help 🙂

    Upon checking the NextGEN Gallery plugin forum, I can see that they have released a patch that seems to fix this issue. Please feel free to check this here:

    https://wordpress.org/support/topic/nextgen-gallery-latest-beta-patch-please-read/

    I hope that helps!

    Thread Starter kraeMit

    (@kraemit)

    Thanks, I already checked the fix. As I can see it helped some others but mine problem is still existent.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.