Support » Plugin: PDF Embedder » after update to v4.3 can’t add pdf embedder to posts

  • Resolved ghubbs

    (@ghubbs)


    Running wordpress 5.2.2 and have pdf embedder premium secure v4.3. After the pdf embedder update we can no longer add any media files to a post. pdf or videos now give the following error: This block has encountered an error and cannot be previewed. If I deactivate pdf embedder I can create posts with videos again. pdf embedder’s update seems to be locking us out of creating blocks.Posts with pdfs or videos published before the upgrade continue to work with out issues.Thanks

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support WP-PDF Support

    (@wppdfsupport)

    Hi @ghubbs,

    The issue is due most likely due to caching but there are some steps to take to identify and/or resolve the issue:

    • Flushing any caching plugins you might be running, as well as server and/or browser caches. Not just your browser, but any op cache or content network cache as well such as Cloudflare. That will solve many weird JavaScript issues.
    • Flushing Managed host caches. Managed WP hosting often has special caches. If your host has a “Purge Varnish” or “Flush Memcache” tool, try that. You can ask your provider to flush memcache and Varnish for you if necessary.
    • Resave your Permalink settings. In a few cases, third-party installers, such as Softaculous, creating sites with slightly incorrect rules in the .htaccess file. While these rules would not have been a problem in previous versions, in WordPress 5+, having these incorrect rules can break the REST API. Resaving the permalinks on the Settings » Permalinks page in WordPress will fix these rules in the .htaccess file, and possibly fix “failed” errors in the new editor.
    • Make sure you have the Visual Editor enabled. Visit your Users » Your Profile page. The first option will disable the visual editor. Make sure that option is unchecked, and save your profile settings.
    • If you have the Gutenberg Developer plugin installed and activated, please disable this—we have heard of issues with the editor and other plugins’ updates throwing this error, and this may be the case here.

    If you have any other questions or require additional assistance, please feel free to send an email to contact@wp-pdf.com as we may not see messages posted here to respond in a timely fashion.

    Emma

    Plugin Support WP-PDF Support

    (@wppdfsupport)

    Hi @ghubbs,

    There appears to be a little code error in the Secure version of the plugin. We have pushed out an update to the Secure version (4.3.1) which rectifies this issue.

    Emma

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.