Support » Plugin: Zotpress » after update to 7.1, in-text just spins wheels

  • Resolved malangali

    (@malangali)


    I think my topic title says it all. I updated to 7.1 this afternoon, and now all of the in-text citations have become spinning gears. The bibliography page renders fine.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author Katie

    (@kseaborn)

    Can you provide some of your shortcodes from that page?

    This is the age of “fake news” and “alternative facts”. The morning starts with presidential prevarication [zotpressInText item=”{ZVNGMZ72}”] on Twitter, or the White House lawyer arguing “truth isn’t truth” [zotpressInText item=”{ACMJDHMP}”]. Facebook sells your personal data while telling you it protects your privacy [zotpressInText item=”{SLCWAAX9},{M7ZHI72B}”]. Top-ranked search results promulgate medical misinformation, with sometimes fatal consequences [zotpressInText item=”{XJ9D5PRG}”]. Much of the Internet is populated with fake businesses, fake people, and fake content [zotpressInText item=”{R7XIKFGS}”]. You yourself are complicit in the culture of lying each time you agree that you have read the terms of service for the apps and websites you use (see Picture 2).

    Plugin Author Katie

    (@kseaborn)

    Thanks, I will try to test on my end. Another thing: Do you have multiple Zotero accounts synced? Do you have a “default” Zotero account set?

    Here is the bibliography page, so you can see that all of the references are produced perfectly using [zotpress collection=”L68MPL5N” sortby=”author”]

    https://www.teachyoubackwards.com/references/

    I only have the one Zotero account. I don’t recall setting a “default”.

    It is working now. Did you do something?

    Plugin Author Katie

    (@kseaborn)

    I haven’t changed anything and I haven’t had time to test on my end. I wonder now if it’s a caching thing?

    Caching seems as likely a culprit as any. It was at least 24 hours between when I ran the update and when I noticed the problem, and at least another 24 hours before it went away, so that’s something to keep in mind if other people experience the problem.

    I’ll just use this moment to reiterate a suggestion from a few months ago, that you include a copy-to-clipboard button for copying the shortcode.

    Thanks for all you do on Zotpress!

    Plugin Author Katie

    (@kseaborn)

    Hmm, I’m not sure, but I suppose it must have been a cache or similar. I’ve also double-checked your shortcodes on my end, and they’re working (with my library items). But do please let me know if it suddenly stops working again!

    Same issue here.
    After the update, the plugin vanished from the dashboard, as it was uninstalled. However, after installing again, all settings were still there.
    With some authors, the list is fine, while for others, the page is completely broken.

    I got the following errors with various tools:

    {“status”:”empty”,”instance”:”zotpress-f1e653be466f6777b2d03842c82e763f”,”meta”:{“request_last”:0,”request_next”:0},”data”:”0″}

    In editor (both Gutemberg and classic), pages with shortcodes are broken and flashes for a second before giving errors:

    TypeError: Cannot read property ‘raw’ of undefined
    at /wp-includes/js/dist/editor.min.js?ver=9.2.6:17:64261
    at Array.map (<anonymous>)
    at /wp-includes/js/dist/editor.min.js?ver=9.2.6:17:64201
    at Td (/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.8.4:82:11)
    ….

    From some logs:

    Undefined offset: 1
    Type: PHP Notice Line: 135
    File: /wp-content/plugins/zotpress/lib/request/request.functions.php

    Undefined offset: 0
    Type: PHP Notice Line: 133
    File: /wp-content/plugins/zotpress/lib/request/request.functions.php

    UPDATE:
    Adding a new account with the same group, name, id and key solved partially the issue. Now the pages did not crash, but they only have the spinning wheel.

    • This reply was modified 4 months, 3 weeks ago by  orion42. Reason: update on the subject
    Plugin Author Katie

    (@kseaborn)

    Vanished from the dashboard? That is a new one. Have you cleared the Zotpress cache for the account as well as any other WP caches? If so, and the issue persists, then please provide the shortcodes that aren’t working, and I will try to check on my end.

    Yes, I’ve cleared the cache and it did not solve the issue.

    [zotpress author=”Name Surname” sortby=”date” order=”desc” highlight=”Surname, N.” download=”yes”]

    [zotpress author=”Name Surname” style=”nature” sortby=”date” order=”desc”]

    [zotpress tags=”tagName” sortby=”date” order=”desc” limit=”3″ download=”yes”]

    I also got further errors:

    First parameter must either be an object or the name of an existing class
     Type: PHP Warning Line: 310
    Undefined property: stdClass::$data
     Type: PHP Notice Line: 310
     File: /wp-content/plugins/zotpress/lib/request/request.class.php
    
    Undefined index: zpcite
     Type: PHP Notice Line: 291, 292
    
    Undefined index: zpnotes
     Type: PHP Notice Line: 283, 284
    
    Undefined index: zptitle
     Type: PHP Notice Line: 275, 276
    
    Undefined index: download
     Type: PHP Notice Line: 267, 268
    
    Undefined index: image
     Type: PHP Notice Line: 259, 260
    
    Undefined index: inclusive
     Type: PHP Notice Line: 251, 252
    
    Undefined index: sort
     Type: PHP Notice Line: 238, 239
    
    Undefined index: sortby
     Type: PHP Notice Line: 229,230,131
    
    Undefined index: data_type
     Type: PHP Notice Line: 189, 190, 191
    
    Undefined index: api_user_id
     Type: PHP Notice Line: 180
    
     File: /wp-content/plugins/zotpress/lib/widget/widget.sidebar.php

    I’m also having the problem described by the OP. Example: https://musi611.meganlavengood.com/su/techniques-for-pop-music/

    Plugin Author Katie

    (@kseaborn)

    @orion42 I’m working on a fix for the shortcodes. Thanks for sharing the logs — I think those errors are fixed now.

    @meganlavengood Can you provide a few shortcode examples, in-text and bib?

    My errors were fixed as described by @katie replacing the styled quotes ” with regular ones ” (see here)

Viewing 15 replies - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.