Support » Plugin: Page Comments Off Please » after update to 4.4 plugin clash

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author techism

    (@techism)

    Thanks for reporting this! I’ll take a look right away and issue an update if I can source the problem to my plugin.

    Plugin Author techism

    (@techism)

    Debug process notes:

    1. Verified normal operation with WP 4.4. on a test website install.
    2. Installing ‘event organiser plugin’
    3. The plugin operates normally, as does page comments off please.

    So far, I am unable to replicate this with the information you’ve kindly provided. May I ask a few more questions?

    1. Which plugin did you install first?
    2. When are you getting this error? (during install? on admin pages? on website pages?)
    3. What theme are you using?

    Currently, http://techism.com is using both plugins and appears to operate normally. I will eagerly repair this as soon as I can replicate. Thank you!

    Plugin Author techism

    (@techism)

    Additional information:
    There are many even organization plugins, I want to verify that you mean this one:

    https://wordpress.org/plugins/event-organiser/

    Since my first tries have not replicated this, these questions might help:
    1. Which version of event-organiser are you using? 2.13.7?
    2. Are you using the pro or free version?
    3. What settings are you using with page comments off please?

    IF you wish, I could take a look your site…

    Plugin Author techism

    (@techism)

    Further testing steps pursued:
    1. Updated the plugin to a new version with added security and tested-up-to tag.
    2. Deleted plugin from test website, while events plugin was running.
    3. Re-installed page-comments-off-please with the latest version.

    Still no replication of the error.

    I wonder if it’s a mysql version problem? (I am testing with v5+)

    Plugin Author techism

    (@techism)

    After reviewing that you have posted this to several plugin developers – I suspect that your update had a problem. You might want to re-install your wordpress core?

    my update indeed had a problem. i re-installed the core, and it is working fine. thank you.

    The “Page Comments Off Please” plugin also clashes with https://wordpress.org/plugins/the-events-calendar/ after WP4.4 update.

    Trying to add a new event throws the error … “You are not allowed to edit this post.” and the “Publish” button changes to “Submit for Review”. I had both plugins running on two sites and same error in both.

    After deactivating “Page Comments Off Please” plugin, the problem above goes away.

    yes, i did deactivate page comments off please after re-installing wordpress core, since the problem persisted when clicking on new event. i deactivated comments a different way (in my child theme) and now there is no problem.

    Plugin Author techism

    (@techism)

    Glad to know we got your WP core fixed.

    Regarding adding events: I am able to add events in a wp 4.4 website that is running Page Comments Off PLease and https://wordpress.org/plugins/event-organiser/

    Everything is working fine with this plugin. I am able to create events, edit them, everything, Will now disable that and test the following:

    https://wordpress.org/plugins/the-events-calendar/

    I have verified the problem reported by Sallymoos. (THANK YOU!)

    I’m not sure at this point which developer is causing collisions. I’ll investigate this and issue any appropriate updates at once. Thanks again!

    Plugin Author techism

    (@techism)

    Still getting to the bottom of this, but there IS a quick workaround: Setting Page Comments Off Please to ‘Legacy Mode’ will resolve this conflict.

    I have verified that both plugins will work as designed with this configuration 🙂

    Plugin Author techism

    (@techism)

    I’ve tracked this down to one line:

    add_filter(‘pre_option_default_comment_status’, array(&$this, ‘disable_page_comments_default’));

    It doesn’t matter what function I link to, even a blank one. Any attempt to filter the pre_option_default_comment_status (the core purpose of my plugin) makes their plugin fail. I believe this to be a problem with their security checks possibly.

    This is why legacy mode still works for you. It was implemented before that filter was available and uses a manual javascript method to uncheck the boxes for you 🙂

    It looks to me like a problem with their plugin that I can’t easily work around. I’ll let them know about this as I can see they are good coders and should be able to handle the feedback.

    In short: Just use legacy mode and you are fine.

    As a repeair for my plugin, I could change

    add_filter(‘pre_option_default_comment_status’, array(&$this, ‘disable_page_comments_default’));

    to

    add_filter(‘default_comment_status’, array(&$this, ‘disable_page_comments_default’));

    And this also resolves the conflict, but I need to test other impacts of that change.

    Plugin Author techism

    (@techism)

    FINAL update: I’ve found a nice way to re-encode the pre_option filter that the event calendar plugin doesn’t mind.

    May I ask ‘sallymoos’ to test the new version before I release it? I can email it to you, or provide instructions to apply the change to your current install.

    Please let me know.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘after update to 4.4 plugin clash’ is closed to new replies.