Fast Secure Contact Form
[resolved] After update to the theme breaks (13 posts)

  1. simco
    Posted 2 years ago #

    Immediately after updating to the latest version of the plugin the entire home page breaks. Deactivating it makes the site work fine. But we have several forms deployed and need them to be present.

    URL: http://www.ncaied.org

    Using an Elegant Themes theme. Have tried deactivating other plugins to see if it rectifies the issue but to no avail.



  2. simco
    Posted 2 years ago #

    Never mind, found the problem! The site owner had slipped the page containing the form into the rotation of the main image slider on the home page and the shortcode for the form wasn't able to parse in the truncated post summary in the slider display. Removed the page from the rotation and all is well.

  3. simco
    Posted 2 years ago #

    On further notice, a problem has arisen regarding memory allocation when activating the plugin.


    Please advise.

    The actual error message, I had to disable the plugin and go with a stock form in the interim:

    Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 262144 bytes) in /home/ncaiedor/public_html/wp-includes/wp-db.php on line 1223

  4. Mike Challis
    Plugin Author

    Posted 2 years ago #

    Low Server Memory
    Some WordPress installs run out of available PHP memory because the memory limit is set too low.
    This can cause random errors or white screens that show no error at all.

    Install this WordPress plugin to see the PHP Memory Limit and Memory Usage in the WordPress admin dashboard:

    What does it say about memory usage?

  5. simco
    Posted 2 years ago #

    Thanks for your super quick response! I installed the plugin, here's what it says:

    PHP Version : 5.3.16 / 32Bit OS
    Memory limit : 40 MByte
    Memory usage : 30.55 MByte

  6. simco
    Posted 2 years ago #

    Quick update, I did change the wp-config.php to add the following:

    define(WP_MAX_MEMORY, '64');

    Or whatever the tag was. Now it shows the 64 Mbyte and 30.55 usage respectively.

  7. Mike Challis
    Plugin Author

    Posted 2 years ago #

    That is not very much server memory and it was all almost full.
    OK, good, see if the plugin works now.

  8. simco
    Posted 2 years ago #

    I did try it... it basically times out and goes kaput.

    Was working fine until the update. Any change I can just get the previous version? Or, find the issue as to why it's struggling here?

    Also, FYI, we do have Jetpack installed. Sometimes plugins conflict with it.

  9. Mike Challis
    Plugin Author

    Posted 2 years ago #

    I have an idea about what could have happened.

    Versions 3.1.8 and were including the wp_session manager 1.1 library and it was storing the temporary sessions in the WP options table. WP session 1.1 has a bug that caused the sessions rows not to purge automatically.

    In version, I removed the wp session manager library and made a function to remove the _wp_session entries from the wp options table in the database. So if your site was very busy, there could be many many database entries and WordPress could potentially time out while trying to purge them. Once they are purged, it does not try to purge them anymore and the plugin should function normally.

    You might have to purge them manually from the sql command in phpMyAdmin

    Here is a help page:

  10. simco
    Posted 2 years ago #

    First, I really thank you for your immediate help. Much appreciated!

    I did run that query and 0 results were found. Unfortunately.

    I see a bunch of crap in the tables pertaining to this:

    _site_transient_timeout_browser_11cb7ba63b8b1cca99 blah blah

    There's a hundred or more of those at least.

  11. Mike Challis
    Plugin Author

    Posted 2 years ago #

    _site_transient_timeout_browser is not related to my plugin.
    transients just cache things for better server performance.

    I suspect the 64meg is just not enough for WordPress with Jetpack, you may need a server upgrade.

    You can try temporarily deactivate the other plugins while you install this one the, then activate them again one by one.

  12. simco
    Posted 2 years ago #

    I run a whole bunch of WordPress sites on this server without issue and use your plugin for each one. This is the first incident of this occurring so i'm going through a process of elimination to determine the cause.

    What i'll do next is deactivate all plugins, leave yours activated and see when it breaks by activating the others individually.

    I'll report back.

  13. simco
    Posted 2 years ago #

    Ok, an update. It turns out it was one of my other suspicions, where it was clashing with another plugin. I replaced that plugin with another one that uses no javascript or jquery and the issue appears to be resolved.

    Thanks again for your help. I'll let you know if anything else surfaces.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Fast Secure Contact Form
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic