Support » Plugin: Display Widgets » After update to 2.6.2 does not work anymore

  • Resolved lion1968

    (@lion1968)



    I have updated to 2.6.2 and now does not work anymore, nothing error but all widget are not diplayed!
    I had to turn off the plugins.

    • This topic was modified 1 year, 1 month ago by  lion1968.
Viewing 8 replies - 1 through 8 (of 8 total)
  • Hello lion1968,

    I have the same problem. At the plugin page the problem is described with a suggestion for the solution:

    My widgets aren’t showing when I activate:
    With some plugins and themes, you may need to adjust when the widget calls start. You can add the following code to your theme’s functions.php:

    add_filter(‘dw_callback_trigger’, ‘dw_callback_trigger’);
    function dw_callback_trigger(){
    return ‘wp_head’; //change to: plugins_loaded, after_setup_theme, wp_loaded, wp_head, or a hook of your choice
    }

    But this is unfortunately no solution for me/my website (but maybe for you), because:
    My theme “Hueman” hasn’t got a normal “functions.php”, but more “function.php-files”, which control the theme. So I don’t know which of those “funcion.php-files” to modify. The “functions.php” in Hueman-theme only says the following:

    <?php

    //Do not remove this
    load_template( get_template_directory() . ‘/functions/init-core.php’ );

    /**
    * The best and safest way to extend the Humean WordPress theme with your own custom code is to create a child theme.
    * You can add temporary code snippets and hacks to the current functions.php file, but unlike with a child theme, they will be lost on upgrade.
    *
    * If you don’t know what a child theme is, you really want to spend 5 minutes learning how to use child themes in WordPress, you won’t regret it πŸ™‚ !
    * https://codex.wordpress.org/Child_Themes
    *
    */

    So… which function.php-file is the right one to modify?
    Further: I use a child-theme, so that I would lose this solution – if it works – on every theme-update. Not nice. πŸ™

    When I deactivate the plugin, all my widgets appear again. Luckily I have the old version 2.05 and I installed it back. Now everything works right again. But it is a pity, of course, that I can not update this plugin any more.

    Regards, edurix

    Okay, in the plugin’s source code (display-widgets.php version 2.6.2), find a line that says

    return (bool) $instance;

    and replace it with

    return $instance;

    Can you let me know if that fixes the problem? If it does, I’ll release the update right away. Thanks for your help.

    Here too, nothing visible anymore… back to the old version that worked without problems. Sometimes those 200.00 users may not be well served with new stuff that doesn’t work :-S

    Hi.
    Similar problem (spaces where sidebar widgets should be but nothing inside) but just tried the solution suggested of replacing
    return (bool) $instance; with
    return $instance

    This worked for me.
    Thanks very much

    Update is now live. As soon as you update your copy, could you please let me know if everything is back to normal now?

    Hi.
    Updated to 2.6.2.1 and all working as it should.
    Thanks so much for responding quickly to this problem.

    @joeburnsleeds you are very welcome!

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    πŸ³οΈβ€πŸŒˆ Halfelf Rogue & Plugin Review Team Rep

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘After update to 2.6.2 does not work anymore’ is closed to new replies.