Support » Plugin: Weather Underground » After update shortcode stops working

  • Resolved piantadosi

    (@piantadosi)


    Installed update and afterwards the [forecast] shortcode in a text widget is not being parsed, just displays as “[forecast]”

    we don’t use the wunderground widget, because we have other stuff that needs to be displayed in the same widget.

    Tried adding parameters, etc., without success. Reverted to 1.2.5.1 and it works again.

    https://wordpress.org/plugins/wunderground/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Zack Katz

    (@katzwebdesign)

    Does it work if you use the [wunderground] shortcode?

    Hi — no, I forgot to say that. Tried it both ways, with [forecast] and [wunderground]. Thanks for any ideas you might have; for now we’re fine with using the earlier version but would like to use the update, which seems we could customize to a greater extent.

    Plugin Author Zack Katz

    (@katzwebdesign)

    Oh, it’s in a text widget – I didn’t see that!

    Please add this to your theme’s functions.php file:

    add_filter('widget_text', 'do_shortcode');

    That did the trick. Thank you, and thanks also for the quick response.

    My shortcodes are not working either. Since I’m having also another problem which I posted in a different topic, I’m reverting back to the old version. This version does not seem stable.

    Same problem here. after updating to 2.0.7 I immediately tried to go into Settings > WU weather to see what was new, and an error displayed something like “you do not have access or insufficient privilege” even though I am an admin. then WU weather disappeared from the admin Settings menu, and the widget on front end only shows “[forecast]” now. I installed the previous version from the link in the plugin’s “changelog” page. Thanks for including that link. Hope this can be resolved soon. And thanks for your efforts.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘After update shortcode stops working’ is closed to new replies.