Support » Plugin: Elastic Email Sender » After update send html code (contact form 7)

  • Resolved heathcliff2013


    After the recent update my contact form 7 is sending html characters. When disabling the elastic email sender plugin I receive my mails correctly. This glitch occurred after the update.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Thread Starter heathcliff2013


    This also happened on 3 of my other websites with your plugin installed.

    **** update

    I learned that after the update “text/html” was unchecked. After checking it I received my emails without the html codes in the body of my email.



    I’ve noticed this too in my WooCommerce emails.

    Thanks for pointing out the fix! As the option was set to Auto (default), which might had not picked up the MIME from WooCommerce emails.

    I too was getting this on WooCommerce emails and Visual Form Builder submissions. Fortunately the fix is rather quick.

    Thread Starter heathcliff2013


    I’m glad my post helps other people with the same problem, I am happy your issues are resolved too @solutioinc @daniel_richard 🙏

    This isn’t just happening with CF7 or Woo, it’s nearly every WP form plugin that uses HTML to format it’s emails.

    This new option of “Mime Type” is defaulting to Plain Text. Going into the Elastic Plugin setting and changing this setting to HTML fixes the issue.

    Simple if you have 1 site, a much more complicated issue when you have 60. Serious oversight from the Elastic Email team, something like this should have been thoroughly tested and obviously was not. We suddenly had 40 pissed off customers who weren’t able to decipher their emailed leads, not a good look.

    Plugin Contributor Rafal


    If the auto option is selected, headers are read and the message is sent according to this type. Extra options are for people who use plugins that don’t add headers. Sending everything as htm or plain text causes problems for other users. You can read more about headers in the email here.

    Thread Starter heathcliff2013


    @rafkwa so why are you doing a fix? (rhetorical question)
    1.2.2 – Fix: Update MIME type after update

    Thanks for the update though

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.