WordPress.org

Forums

WooCommerce - excelling eCommerce
[resolved] After update: Products not found when clicked on in shop (3 posts)

  1. optymizer
    Member
    Posted 1 year ago #

    After updating my plugins, when I click on my products I get the "sorry we can't find what you are looking for" page. This is for every product. I have tried changing permalinks, but nothing works.

    I also tried the suggestions in this topic, but nothing worked (it is an old topic, but it was all I could find)
    http://wordpress.org/support/topic/plugin-woocommerce-woocommerce-pretty-permalinks?replies=19

    I tried deactivating and reactivating woocommerce. I tried it with other plugins deactivated.

    I am using WPML as my site is in Hebrew. I am using the StoreBox Theme Version: 1.3 (based on GavernWP 1.9)

    Please help. I currently have a coming soon plugin hiding the site or I would include the link.

    I can email user and pw for anyone who can help me.

    Thank you,
    Sarah

    http://wordpress.org/plugins/woocommerce/

  2. Colin Young
    Member
    Posted 1 year ago #

    Hi Sarah

    A couple of things to check first would be

    1. When you hover over a product and you can see the link at the bottom of your browser, does it make sense (does it look the way you would expect)?
    2. Your products, for some reason, haven't become hidden have they?

  3. optymizer
    Member
    Posted 1 year ago #

    I finally figured it out. It was an issue with the WPML plugin and string translations. After I updated the WPML plugins, there were new URL strings to translate and once those were translated, the products showed up correctly.

    Thank you for your quick response!

    Sarah

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce - excelling eCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic