Support » Plugin: Custom Content Type Manager » After update cctm permalinks /%postname% doesn't works for my custom types

  • queengab

    (@queengab)


    Hi to all,

    and thanks for this precious plugin. I have used cctm with no problems since i had to update my wp core and the plugin.
    I update the core from 3.5 to 4.1 and the cctm plugin untile the last version.
    I imported all my types with json import and all works fine. But, if previously permalinks postname works very well also with custom post type now.. something was wrong.
    I tried to change permalink structure to update the permalink rules.
    Tried to use Function Reference/flush rewrite rules but nothing happens.
    Tried to edit custom postname, save and then return to the original configuration.

    The strange thing is that if use Day and name permalink my custom content types display well! with the right url but post take also say and name structure on url taht i don’t want.

    I can’t understand how to resolve.

    Someone have suggestions?
    Gabriele

    https://wordpress.org/plugins/custom-content-type-manager/

Viewing 4 replies - 1 through 4 (of 4 total)
  • willcoffin

    (@willcoffin)

    Hey there CCTM Community!
    Love this plugin, Everette is great!
    Having the same problem as queengab though. Here is my test scanario.

    Scenario 1:
    Content Type Name: “Exercises”
    Rewrite with permalink front: ON
    Categories & Tags: ON
    CCTM Cache Cleared
    Wordpress Permalinks Refreshed (Flush rewrite rules)

    1. Create New “Exercise” Post “TestExercise003”
    -Permalink Autopoluates to “Permalink: http://dummysite.com/exercises/testexercise003/”
    -Add Dummy Text to Body
    -At this point, BEFORE SAVING OF ANY KIND, if I click “View Exercise” it displays propertly at “http://dummysite.com/?post_type=exercises&p=300&preview=true”
    2. Click “Save as Draft”
    -“View Exercise” shows the post correctly (Same url as above)
    -“Preview” button works the same as “View Exercise”, correctly
    3. Click “Publish”
    -“View Exercise” sends you to “http://dummysite.com/exercises/testexercise003/” and returns a 404 error
    -“Preview Changes” also returns a 404 at url: “http://dummysite.com/exercises/testexercise003/?preview_id=300&preview_nonce=213e7385b2”

    Also, I have a custom plugin that displays these posts using a loop based on their ID and they display fine there as well.

    So the permalink URL’s are not getting written properly for some reason.
    I even tried turning off custom permalinks all together to see if that fixed anything and nothing changed, but I will test this again with a little more structure.

    Anyone have ideas?

    Everette I am happy to chip in for an hour or so of your time to fix this if it has to do with CCTM 🙂

    I’ve installed CCTM in a fresh WP 4.1 and permalinks returns 404 page too.

    Same here, but I reverted back to the older version of CCTM, and it worked again.

    However, If you have already updated wordpress to the latest version, you can try going to EDIT the post type, Go to ADVANCED, then check the box “Enable Archives” then click save, then uncheck the box “Enable Archives” then save again. That worked for me on a dummy test site that I had already updated the WordPress 4.2.2 in. If you haven’t udpated to 4.2.2, then reverting back to an older version of CCTM worked without having to enable archives.

    This is the link for that issue:
    https://code.google.com/p/wordpress-custom-content-type-manager/issues/detail?id=588

    Hello,
    Can you help me with a problem? I tried the the above solution to check Enable Archives and it is already checked. Unchecking saving and then rechecking and saving still gives me the 404 error but after I save the permalinks in the settings, it goes away but leaves me with an error message displaying with the posts.

    http://ritashulte.com/heartline
    http://ritaschulte.com/testimonials
    http://ritaschulte.com/consider-this
    http://ritaschulte.com/book-quotes
    http://ritaschulte.com/book-reviews

    I could not figure out what was going on and tried to deactivate different plugins to fix the problem. I went into the settings and resaved the permalinks and the content returned; however, there are a couple other problems now.

    On each main display page it has this line displaying:

    Warning: Illegal offset type in isset or empty in /home4/siftedas/public_html/wp-includes/post.php on line 1160

    I tried to deactivate the plugin once again and reactivate it but then I got the 404 error once again. After resaving the permalinks I am back to the content returning with the warning error.

    I then went into one of the postings and the audio player was not showing. Everything was set properly and the audio file checks valid. I noticed on a couple posts that had a featured image, the audio player was displaying. I went back to the other post and added a featured image and yes, it then displayed the player. However, going into another post without the featured image and adding it did not display the audio player. The plugin used for the audio content is Blubrry PowerPress. I can fix the audio player problem by using a different plugin but I need to know how to remove the warning line.

    Thank you for any help you can give,
    Shawn

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘After update cctm permalinks /%postname% doesn't works for my custom types’ is closed to new replies.