Support » How-To and Troubleshooting » after up to 2.8 plugin autoupdate problem

after up to 2.8 plugin autoupdate problem

  • Hello,

    i cannot autoupdate all plugins after upgrade to 2.8.

    Downloading update from http://downloads.wordpress.org/plugin/my-category-order.2.8.zip.
    Unpacking the update.
    Inkompatibles Archiv PCLZIP_ERR_MISSING_FILE (-4) : Missing archive file '/srv/www/******/******.de/httpdocs/wp-content/upgrade/my-category-order.2.8.zip'

    Same error with all plugins!!!

    Before upgrade all jobs was working fine. I have not change anyone, only autoupgrade to 2.8.

    Any idea to fix this problem?

Viewing 15 replies - 1 through 15 (of 19 total)
  • Same here:

    Downloading update from http://downloads.wordpress.org/plugin/nextgen-gallery.zip.

    Unpacking the update.

    Warning: unlink(/***/***/***/html/blog/wp-content/upgrade/nextgen-gallery.zip) [function.unlink]: No such file or directory in /var/www/web81/html/blog/wp-admin/includes/class-wp-upgrader.php on line 146

    Inkompatibles Archiv PCLZIP_ERR_MISSING_FILE (-4) : Missing archive file ‘/***/***/***/html/blog/wp-content/upgrade/nextgen-gallery.zip’



    Forum Moderator

    Try downloading the upgraded plugins and the uploading them to the relevant plugins folder manually via FTP.

    Yeah, that works, of course – but I’d rather get the auto-update working again. 😉

    i have this problem with all plugins, not alone with nextgen-gallery!

    the nexgen gallery often is wrong, the actual version is very crude, i hate this plugin.

    manually update works, but the bug with automatic uploads is not fixed with this!

    Hello programmers!

    Any idea to fix this heavy problem?

    Downloading update from http : //downloads.wordpress.org/plugin/some-plugins.zip

    Unpacking the update.

    Inkompatibles Archiv PCLZIP_ERR_MISSING_FILE (-4) : Missing archive file ‘/srv/www/vhosts/********/httpdocs/wp-content/upgrade/some-plugins.zip

    @tillo: I know, I’m having the problem with all other plugins, too. Nextgen was just an example. It used to work fine before.

    I notice your error message is in German as well – so maybe it’s a bug in the German version?

    No, i tried the german and the english version.

    Guys I was using Turkish version of 2.7.1 and when I update it updated from this site of course, so I had this error too. But when I update it from that Turkish site I originally installed wp2.7.1 it solved the problem and now I can use my auto-upgrade. Though at another host I installed from this sites original 2.8 I cant use it now it gives blank page and doesnt seem to accept my FTP infos that I use to upload every files, lol 🙂 Auto-upgrade seems to suck these days.

    @arzlonga: I believe you are right! Like you, I just clicked “update now” in the backend when it told me that 2.8 was available. But instead of the German version, it installed the English 2.8 files. Maybe that was causing the problem!

    I just downloaded the full German version from the German WordPress site. I copied it to my server and hope that the error will be gone now – I can’t test it right now because no plugins need to be updated at the moment… 😀

    The german version has the same problem!

    You don’t understand what I’m saying:

    – go to http://wordpress-deutschland.org/
    – download and unpack the .zip file
    – upload the whole thing to your server, overwriting the old files


    If the autoupgrade is not working, read and follow Upgrading WordPress.

    I have solved the problem for me:

    In wp-config.php, I had added the following line:
    define('WP_TEMP_DIR', ABSPATH . 'wp-content/upgrade');
    because without that line, my auto-update wouldn’t work in WordPress 2.7.

    Now in WordPress 2.8, it seems that the auto-update won’t work with that line. 😉 So I removed it and everything’s working again!

    Strange enough:

    Just correcting the double slash in wp-config.php did not solve the problem, commenting the whole line out by adding // at the beginning of the line worked for me too



    I cannot find the upgrading instructions on how to upgrade 2.7.1 to 2.8.1.

    I also got some errors when upgrading to 2.8.1 in my blog http://followta.com/blog/

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘after up to 2.8 plugin autoupdate problem’ is closed to new replies.