WordPress.org

Forums

Jetpack by WordPress.com
[resolved] After the Deadline Spellchecker 404 error (13 posts)

  1. BeRKA
    Member
    Posted 1 year ago #

    I haven't changed anything. This used to work. Now I get an error on my blogs. Below is one example:

    GENERAL
    404
    At: http://zho.berka.com/wp-admin/admin-ajax.php?action=proxy_atd&url=/checkDocument

    https://wordpress.org/plugins/jetpack/

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    I tried to access your site, but received the following message:
    http://i.wpne.ws/TttX

    It may also be what's blocking communications between your site and the Spellchecker service on WordPress.com.
    Could you try again once your site is publicly accessible?

    Thanks!

  3. BeRKA
    Member
    Posted 1 year ago #

    What IP address are you using?
    What IP address is the Spellchecker service using?

    I'll check if these are blocked.

  4. BeRKA
    Member
    Posted 1 year ago #

    I have now tried removing all entries in my htaccess and it still don't work.

  5. BeRKA
    Member
    Posted 1 year ago #

    My site should be accessible for all except east-european and chinese hackers/spammers. I have removed all entries in my htaccess and I still have the same problem with the Spellchecker.

    I haven't heard any complants from my visitors either. So I guess that they can see my site without any problems. I can see my site from 3 different IP addresses. Jetpack Monitor isn't complaining either.

  6. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Hi there,

    Jeremy told me that he still had issues connecting to your site from his computer, but the connection appears to be ok from the WordPress.com servers. However, we still have an issue when trying to post xml to your xmlrpc.php file. DO you have any security plugins or other htaccess rules that may be blocking something?

  7. BeRKA
    Member
    Posted 1 year ago #

    My security plugin is Wordfence.
    If I deactivate it, I still have problem with the Spellchecker.
    I have also deactivated all of my plugins and the problem is still there.

  8. BeRKA
    Member
    Posted 1 year ago #

    Is there any changes in WordPress 3.8.1 that can have caused this?

  9. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    I've asked the Jetpack developers to take a look at this, as there is now another thread with the same issue:

    https://wordpress.org/support/topic/after-the-deadline-not-working-on-381-jetpack-clean-install?replies=2

  10. asherwolf7
    Member
    Posted 1 year ago #

    I posted this on my other thread, but I thought I'd post this here too.

    The problem for me was my web server. The 404 error code was being generated by an actual 406 error code. 406 error codes are usually generated by mod_security, a module that exists on many web servers server-software (apache). This module filters all post requests and other things according to a set of rules. So, as soon as I'd post something to the wp-admin directory that wasn't whitelisted it would fail. But it wasn't a 404, but a 406. I determined this by temporarily disabling my index.php file and cUrling the server for an unadulterated result (the index.php page wasn't able to handle the 404).

    For some people the solution is to put a mod_security exception into an .htaccess file either at the top directory, or the wp-admin directory. I tried that, in several forms, but it either didn't work, or gave me a 500 internal server error. Unfortunately this is not really the best option anyway as it can expose your website to troublesome atack-traffic.

    Finall the solution for me was to contact my hosting company through a ticket aboud their mod_security set up. Since they were interested in keeping my business they modified the mod_security rules to allow this type of traffic (I don't know the details) and now my proofreading post to wp-admin/admin-ajax.php?action=proxy_atd&url=/checkDocument works beautifully across my whole server.

    Hope this helps the next guy, I spent all day on this.

    Asher

  11. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Thanks so much for the detailed answer, Asher! I'm glad you were able to find it; too bad it took you a whole day to do so. :(

    BeRKA, could you check with your host, point them to this thread and Asher's detailed response, and see if they can help you? Let me know what they tell you.

    Thanks!

  12. BeRKA
    Member
    Posted 1 year ago #

    Yes, it was mod_security for me as well. The problem is fixed now.

    Thank You Asher!

  13. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Yay, glad everyone got this resolved! Thanks for the assist, Asher!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic