Support » Plugin: MailPoet - emails and newsletters in WordPress » After Signup on website, there is NO “thank you” page

  • Hello,
    This may be a strange question, but when someone signs up to my newsletter, he is redirected to … nowhere (/?mailpoet_page=subscriptions&mailpoet_router&endpoint=subscription&action=captcha&data=xxxxxx).
    Should there be a page where he is redirected, for example, saying…
    “Thank you for signing up to our Newsletter. You will need to visit your email to confirm your signup”.
    Any help with this is appreciated.
    Thank you!

Viewing 3 replies - 1 through 3 (of 3 total)
  • @marogiannis

    I am having the same issue as you. Did you resolve the issue?
    Thanks.

    Plugin Author MailPoet

    (@wysija)

    Hi @marogiannis,

    It seems you have the build-in captcha option enabled and the captcha page is not working.

    Please go to MailPoet’s Settings page > Advanced tab and set up the “Google ReCAPTCHA option” instead.

    Let us know if it works!

    Thread Starter marogiannis

    (@marogiannis)

    Hello!

    Thank you for your reply! … however Just too many problems!
    No, it didnt work. It only works if Captcha is off.

    Another thing, I am super admin in the WP dashboard, and I have set English as default language for me. WHY am I seeing the language the WP was set up in?? Everything else is in English except MailPoet.

    Unfortunately, my customers are already moving to the other known alternative. Thank you anyway.!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.