Support » Plugin: ALO EasyMail Newsletter » After relaunch page slug is no longer included in URL?

  • Resolved allthebugsandmore

    (@allthebugsandmore)


    Ciao Allessandro and thanks a lot for your great plugin!
    It has been doing its trusty job just fine on one of my projects,
    and did that without problems for quite some time now.

    After a while the whole former project required a complete redesign and redevelopment under a temporary domain, pointing to a folder on the same server, side by side with the first version. So that should not be a cause for trouble.

    I did the new site setup from scratch and used a database dump from the first site to make use of the content again. During the setup several former plugins flew out or got replaced by others, one i coded myself and my “favs” were installed again – so was Easymail.

    After setup of Easymail i had only done a rather rough check to see if everything would be working as expected. And so it seemed back then.

    Now, after switching domains yesterday, i rechecked everthing upon proper functioning again. And by doing that with Easymail, i saw, that the links to confirm and to unsubscribe don’t work and that clicking the link to see the online version will be led on to open the start page.

    Example confirmation link: https://www.domainname.de/?lang=de&emact=YXNj….
    Example unsubscribe link: https://www.domainname.de/?lang=de&emunsub=MXw….

    The page “Newsletter” is setup and contains the shortcode.
    Calling it shows the form. Filling the form field with an eMail address leads to an outgoing mail, informing the sender that he/she needs to confirm. All fine.
    Except the confirmation URL is incomplete and thus can’t work.

    I found out,
    that the slug /newsletter/ is missing in the URL.
    Manually entering https://www.domainname.de/newsletter/?lang=de&emact=YXNj… in a browser seems to do the trick with the confirmation code and the unsubscribe code.
    However, the regular online page output of a newsletter still leads to a “Page not found”. With that missing i could live, without the basic functions of subscribing and undoing that not so much…

    I read through your FAQ, tried “this&that” and yes, i have saved the permalinks too serveral times.
    After searching, trying and failing for some hours now, i am tempted to hard code the missing slug in the function writing the URLs – but i’m sure that there must be another way to make Easymail work as it did for years now…

    Do you have any idea/hint what could prevent the new setup from building the complete URLs? Or perhaps a “cure” to that?

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author eventualo

    (@eventualo)

    Hi, have you checked if the newsletter page is properly set in plugin setting? You can check it on Newsletters → Settings → tab General.
    Maybe you already set it but I tell you just to be sure.

    Thread Starter allthebugsandmore

    (@allthebugsandmore)

    I confirm that I did,
    and that I did it again, a moment ago just to be sure.
    Tab General shows “#9659 Newsletter,”
    which is the ID of the page containing the Shortcode [ALO-EASYMAIL-PAGE].
    Then i went over to PAGES and checked the one with ID9659:
    Its title: is “Newsletter”,
    the permalink right below that is “https:/www.domainname.de/newsletter” which leads correctly to the page
    Template is Standard, status is Published
    The project uses Elementor, so i opened the newsletter page in that and can confirm,
    that [ALO-EASYMAIL-PAGE] is placed and showing the form in output view just as it should.

    After that, just following a hunch,
    i changed the permalink from “newsletter” to “newsletters”, cleared the caches of “Fastest Cache” and had the database cleaned up by “RVG Optimize Database”.
    Strangely though, calling https:/www.domainname.de/newsletters (with the ending s now) either manually or by use of the corresponding menu button, got me rerouted straight to the start page instead of to the newsletter page…

    Next, suspecting colliding plugins, i started with deactivating “Wordfence Security” – cleared caches and database – saved permalinks – clicked Newsletter menu button – still got led to the start page
    I sequentially deactivated – one step at a time – every even remotely suspicious plugin and kept being led to the start page.

    Now, i’m surely not an expert for .htaccess, but whithout any changes for the better, i even checked that file and wasn’t able to identify anything pointing to “newsletter” or another rewrite that could do the rerouting.

    So as nothing had done any good, i went back to PAGE 9659 and changed the permalink back to “…newsletter”, reactivated every plugin, cleaned cache and database, clicked the menu button and …arrived on the newsletter page, just like it had before the test runs.

    And now for the funny part!
    Like i had already done several times before, i checked entering a new email address just for the heck of it and had it send. Moment later the confirmation mail came in just like before.
    In the eMail i clicked the seemingly incomplete confirmation link https://www.domainname.de/?lang=de&emact=YXNja… also just like before and saw… that it opened a new browser window with that link …and that this very link suddenly got changed to https://www.domainname.de/newsletter/?lang=de&ac=activate&em1=….. followed by the newsletter page, showing the info about “successful confirmation”!!!

    Crosschecking the subscriber list, my new entry is all just fine!

    Well, i have absolutely NO idea why it works now!
    But without any clues or evidences one simply has to be gratious that it does
    …and hope for the best.

    Grazie per l’aiuto
    and keep up your good work!

    Plugin Author eventualo

    (@eventualo)

    Happy for the happy end! Maybe it was an issue somewhere in cache layers and your disable/re-enable refreshed all the things.

    • This reply was modified 1 year ago by eventualo.
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘After relaunch page slug is no longer included in URL?’ is closed to new replies.