[resolved] After Permalink type changed, I'm getting 404 Error at index blog's (6 posts)

  1. user02
    Posted 10 years ago #

    Hi guys, I'm working on a blog, and once I've turned on the Permalinks (Date and name based), when I try enter in the blog by the "Blog address (URI)" I get:

    "An error has occurred
    404 - The requested page could not be found."

    But this message is inside the blog, so if I click on the title at the top, I go to home without problems.

    Let me explain... when I enter in "http://www.domain.com/blog" It takes me to "http://www.domain.com/blog/index.php/". But If I try enter in "http://www.domain.com/blog/index.php" without the "/", works fine.

    WordPress directory: "http://www.domain.com/blog/wordpress"
    Index blog: "http://www.domain.com/blog/index.php"

    Does someone got a solution?

  2. user02
    Posted 10 years ago #


  3. Chris_K
    Posted 10 years ago #

    Got a link?

    Checked out troubleshooting sections at Permalinks and/or Using_Permalinks?

    Confirmed with host that mod_rewrite *and* AllowOverrides are both enabled?

  4. user02
    Posted 10 years ago #

    I asked about the mod_rewrite to the host support and they told me that turned on the mod_rewrite in my acc. I think I just need to make when I enter in "http://www.domain.com/blog", redirects me to "http://www.domain.com/blog/" and not to "http://www.domain.com/blog/index.php".

    ps: > http://www.aDomain.net/user (doesn't work right, it takes you to .../user/)
    > http://www.aDomain.net/user/index.php ( working fine)

    [moderated: obscured urls at OP's request]

  5. moshu
    Posted 10 years ago #

    The two URI values in Options > General should never end in a file name - ONLY directory name!

  6. user02
    Posted 10 years ago #

    Thanks moshu, also HandySolo.

    (edit: thanks mod.) So, I changed the status to "solved".

    Thank you guys.

Topic Closed

This topic has been closed to new replies.

About this Topic