Support » Networking WordPress » After multi-site setup comments and links don't work

  • Ok, So i took the plunge and upgraded my site to multi-site. I am using the URL I am hosting this on my own server using abyss web server.

    All of the content system seems to be working fine. As the admin I can add pages, post comments, add users, add sites, etc. the problem is that all of the links on each of the given pages whether its a comment link, link to previous post, calendar links, etc do not work and my server pops up a 404 error. I am using sub domains and I have my host configuration setup properly through godaddy. I can get to each of the new sites I created via their sub domain from anywhere. The main page of each site loads correctly and I can see everything I have posted from the admin area but if I select a link on the page (any link) it gives me a 404. My assumption is that I have the folders of my web server setup incorrectly for multi-site. But I really can’t figure out where after peeling through the setup again. – main site (original site) – second site – third test site

    Any help would be appreciated. Thanks in advance!

Viewing 15 replies - 1 through 15 (of 16 total)
  • What’s in your .htaccess?

    This is in the root directory of my directory. All the other sites are subdomain sites under this one.


    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    If you’re using subdomains, the CORRECT .htaccess is

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    # END WordPress

    Ok, I updated my htaccess file with what you suggested and dropped it into the root directory. No change. What else should I do?

    Can you get into the admin ends?

    If so, try resaving permalinks.

    Yes, I can get into the admin area of each site. I am the sole user/admin and am able to do anything and everything in the dashboard for each site. I don’t know what you mean by resaving permalinks. How do I do this?

    ok, I just found it. Sorry about the hasty reply.

    Ok, at the moment the permalink structure is set to custom, which I don’t remember doing. Below is what is in the blank.


    If I remember correctly I used the default format upon the original install. Example –

    I know some permalinks structures cannot be used in a sub-domain or sub-directory setup.

    Do you know how to change permalinks?

    Go to the Settings → Permalinks panel and click save.

    We posted at the same time. Read above reply before the following message


    Updated the permalinks by selecting save again and actually going back to the main dashboard for and did the same. No difference. What’s next?


    I think i fixed it. I changed the permalink setting just for the site and all the links seem to be working. I changed the link structure to

    If I update all of the sites with this permalink structure do you think there will be any problems this might create with multi-site? Thanks alot for your help on this!

    That should work BUT the fact that you have to put index.php in there means your server is set up …. weirdly. You’re probably going to run into other errors :/

    Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    ‘Powered by Abyss Web Server X2″

    does that even support the use of htaccess?

    the thing is that I didn’t even put that in there. the script auto populated the fields.

    Abyss does not support htaccess but it does support alot of security features.

    I really don’t want to change servers as I have been using abyss for 7 years and it supports a gammit of the features I use daily for server administration.

    Is there anyway around the index.php in the permalink? I’ll update the permalink structure and see what happens.

    Abyss does not support htaccess

    Then you’re in for a world of hurt. The index.php is there because the .htaccess isn’t working. So … whatever alternative you’ve got to it, you need to sort it out :/

    Thanks for the info…..

    I’m just a little confused as to why its a problem. Everything is working, but you seem to be an expert because you helped me get this far, what issues could this create? I appreciate your help.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘After multi-site setup comments and links don't work’ is closed to new replies.