Support » Plugin: Migrate Guru: Migrate & Clone WordPress Free » After migration all images are gone

  • Resolved Marc Bijl

    (@newoceans)


    After a great first experience with this tool (see my 5 star review a few days ago), I have some trouble right now with another migration.

    After migrating, all images at the site are gone:
    https://snag.gy/IFATXH.jpg

    Also the media library does not show any image:
    https://snag.gy/CedphU.jpg

    Comparing source and destination image folders with ftp, they seem identical:
    https://snag.gy/PmAyKl.jpg

    Any idea where it might go wrong? I’ll take a quick look myself, although I have not the time right now to do a detailed investigation; so because of the deadline I might go with another solution today, but I’d like to know where this goes wrong…

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hmm…

    For some reason I get references to the private_html folder in the source. For example, the site tries to search the images (and some css files) in the private_html folder, while they’re stored in the public_html folder.

    No idea why this is happening…

    When migrating I needed to enter destination path. First I entered nothing, since the site needs to into the root. However, it didn’t work. Checked with FTP where the destination was, and guessed I needed to enter ‘/public_html/’ in the destination path.

    Everything worked fine, the site got migrated. However, the image links received a reference to private_html. Which does not work…

    Managed to migrate through Installatron in DirectAdmin. It has an ‘Import WordPress installation’ option from different destination, which went fine.

    So happy my migration got solved.

    However, still don’t know why Migrate Guru created and applied a private_html folder, and so kind of ‘removed’ all images from the site and media library.

    Might it be, because I tried to migrate from https://subdomain.mysite.nl (developing enironment in a subdomain of my own site) to https://www.clientsite.com?

    Goto settings > Permalink > Common setting> select post name and save. That should help

    Plugin Author akshatc

    (@akshatc)

    Marking this as resolved.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘After migration all images are gone’ is closed to new replies.