WordPress.org

Forums

WordPress HTTPS (SSL)
[resolved] After migrating website, can't login (2 posts)

  1. askwpgirl
    Member
    Posted 10 months ago #

    I am migrating a website to a new domain, and I can't login to wp-admin on the new domain because the WordPress HTTPS plugin keeps redirecting the login to the old domain. I have tried these instructions:

    http://wordpress.org/support/topic/https-force-admin-ssl-breaks-admin-how-do-i-disable

    As well as doing the line in the wp-config file.

    I have removed all references to the plugin and any ssl settings in the options table -- just about everything possible to get rid of this redirect, and I can't keep it from redirecting. This really shouldn't work this way that the admin SSL redirect is so thoroughly obscure in the database that it can't be disabled via phpMyAdmin or by deleting the plugin.

    If you can please tell me where the wp-admin redirect is stored in the database, that would be good for your FAQ as I'm sure many people experience the same issue. Knowing the EXACT database location that is forcing this redirect when the site has been restored from a different domain is crucial.

    https://wordpress.org/plugins/wordpress-https/

  2. askwpgirl
    Member
    Posted 10 months ago #

    Okay, I got it to work.

    This is what worked, but see below for why I thought it didn't work.

    I added this line to my wp-config.php file:

    define('WPHTTPS_RESET', true);

    I then visited a page on the site, then commented out that line.

    The problem I had was that Firefox (and other browsers) CACHE Redirects, so while this worked, I didn't think it worked because the browser had cached the redirect! D'oh!!! Logging in on another browser worked, so the moral of the story is to remember that those silly browsers do tend to cache redirects requiring you to completely delete your current browser's cached files and perhaps restart the browser.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.