Support » Plugin: Premmerce WooCommerce Product Filter Pro » After Latest Woocommerce Update, Product Filter is squished

  • Since the latest update to Woocommerce 3.5, the Premmerce Woocommerce Product Filter is “squished”. I do not know what is causing this. I tested the default theme filter and it displays its regular width. Please help me in figuring out what is causing this issue.

    Thank you.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Premmerce

    (@premmerce)

    Hi, @caveman39!

    Try to change filter style from Premmerce to Default in Settings tab
    http://prntscr.com/ldhc45

    Hello, I tried that and all that did was remove the border around the filters.

    Plugin Author Premmerce

    (@premmerce)

    Hi, @caveman39!

    After a detailed analysis of your problem, we found that this class https://prnt.sc/lejj6s break filter styles.

    Try this way for resolve your issue: add custom css to Additional CSS:
    .widget_premmerce_filter_filter_widget {width: 100%!important;}
    http://prntscr.com/lek45i

    Thank you for the help! That custom CSS snippet resolved the problem. Another issue that I am having though is the AJAX for the filter. When ajax is enabled and when trying to select a filter, nothing happens. Once the filter is selected, the ajax loading circle appears but then disappears and the selected filter is deselected. For the AJAX strategy, I have tried both the Woocommerce content and Product Archive but there is no difference.

    Plugin Author Premmerce

    (@premmerce)

    You check AJAX strategy with http or https?

    Okay, I saw that it was going to HTTP and not HTTPS. Fixed that so now AJAX works. On mobile it works fine. On desktop, it works when selecting a filter but it doesn’t show the images of the filtered products. I can hover my mouse and see a clickable space but no image shows. The images show fine on mobile though.

    Plugin Author Premmerce

    (@premmerce)

    Have you tried both AJAX strategies with https?
    Because it’s not a normal filtering
    http://prntscr.com/lhd7ho

    caveman39

    (@caveman39)

    Yes, I have tried both. They produce the same issue

    Plugin Author Premmerce

    (@premmerce)

    Sorry, but it’s looks like your theme was built not as default theme for WooCommerce. You can try this feature with Storefront or our theme SalesZone.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.