Support » Theme: Page Builder Framework » After latest update 2.6.20 woocommerce only shows one product per col

  • Resolved gavpedz

    (@gavpedz)


    Despite the setting in customizer set to three products per row and grid/list view set to grid as it always has been it now only shows one per row since the last update

    • This topic was modified 1 year, 3 months ago by gavpedz.
    • This topic was modified 1 year, 3 months ago by gavpedz.
    • This topic was modified 1 year, 3 months ago by gavpedz.
    • This topic was modified 1 year, 3 months ago by gavpedz.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 19 total)
  • Theme Author David Vongries

    (@davidvongries)

    Hi @gavpedz,

    I just had a look at the link provided and everything seemed fine to me. There were some issues related to the most recent Elementor updates which affected the product loops. 2.6.20 should have fixed all remaining issues. Make sure you are also running the very latest versions of Elementor & Elementor Pro.

    Do you still get the same issue running all the latest versions?

    Thank you.

    Best,
    David

    Thread Starter gavpedz

    (@gavpedz)

    Hey sorry I had to restore a backup prior to the update so it does look fine now.

    All plugins were up to date. As soon as I restored a backup the the previous version all was fine again as you can see.

    Thread Starter gavpedz

    (@gavpedz)

    Just to update this. I notice the latest update has addressed this but it’s not addressed on category pages. It used to be that whatever amount of products you set for the shop page grid would be the same for the category pages however this is still not the case and category pages are still showing one product per row.

    Theme Author David Vongries

    (@davidvongries)

    Hi @gavpedz,

    Can you please provide me with a link to a category page where this is happening for you?

    Thanks.

    Best,
    David

    Sorry to hijack the thread.

    Previously i have posted about the woocommerce shortcode issue. I have updated your theme and now I am facing this issue.

    Check out my homepage: https://hydrofy.sg/

    Running latest version of elementor free, using shortcode widget.

    EDIT: you will not be able to see the error on my website now because I have replaced the elementor shortcode widget to Elementor Essential Add On Woocommerce widget. I can’t have the problem stays on my web while operating.

    Problem still persists with WooCommerce shortcode for your current theme version.

    • This reply was modified 1 year, 2 months ago by 23bryan.
    Theme Author David Vongries

    (@davidvongries)

    Hi @23bryan,

    I am not able to replicate the issue on my end. The shortcode renders fine for me.

    Here’s my setup:

    – I have set a header in Elementor displayed on all pages of the website (to make sure Elementors code that used to interfere with ours is present)
    – Add a WooCommerce shortcode to the page like this: [products limit="4" columns="2"]
    – Then, also tried to remove the Elementor header. Same result. Everything renders fine on my end.

    This seems to be an edge-case but I’m not sure how to exactly recreate this. Do you have any idea what could cause it?

    Best,
    David

    Hi David,

    This is a screenshot from my end if I uses woocommerce shortcode. https://ibb.co/0YjnWW5

    I have no idea what could cause it

    The shop and product-category page are fine.

    Just the shortcode doesn’t work.

    • This reply was modified 1 year, 2 months ago by 23bryan.
    Thread Starter gavpedz

    (@gavpedz)

    Ok, let me see if I can make this clear. I have just made a copy of the site we have on a staging server. You will need to enter http auth to see it (info below)

    https://avapien526.e.wpstage.net/ this site is running 2.6.21
    http auth
    user:blogvault
    pass:3390def1

    This live site is running 2.6.18
    https://www.avapien.co.uk/

    Offending pages which result in products going to one per line despite no changes to settings the only change is the update of the theme.

    Shop Page
    https://www.avapien.co.uk/shop/
    https://avapien526.e.wpstage.net/shop/

    Category page
    https://www.avapien.co.uk/product-category/shortfill-50ml/
    https://avapien526.e.wpstage.net/product-category/shortfill-50ml/

    Individual product page RELATED PRODUCTS
    https://www.avapien.co.uk/product/aloe-vera-50ml/
    https://avapien526.e.wpstage.net/product/aloe-vera-50ml/

    None of these pages are edited with elementor they are just default although we do have elementor and elementor pro installed and used on the site.

    Theme Author David Vongries

    (@davidvongries)

    @23bryan, are you running version 2.6.21 of the theme? I was not able to replicate this either.

    Thread Starter gavpedz

    (@gavpedz)

    Yes as I said in my above post the staging site https://avapien526.e.wpstage.net/ is running 2.6.21 and is only showing 1 product per row on all the linked pages i mentioned (categories, shop page and individual product page related products)

    Theme Author David Vongries

    (@davidvongries)

    @gavpedz, I was referring to @23bryan in my last reply. I’ll get to your replies now πŸ™‚

    Thread Starter gavpedz

    (@gavpedz)

    Oops so you were sorry

    Theme Author David Vongries

    (@davidvongries)

    @gavpedz, I realized what’s causing the issue. It doesn’t happen for me because I have the Premium Add-On installed which causes the CSS to be loaded AFTER Elementors CSS.

    So in your case, the CSS I’ve added with the recent update doesn’t take effect.

    The fix for this should be simple, I will make sure that particular CSS snippet is loaded after Elementors & PBF’s styles.

    Thread Starter gavpedz

    (@gavpedz)

    Great thanks!

    Theme Author David Vongries

    (@davidvongries)

    Alright, I think we got it! πŸ™‚

    Can you both please try to install the current dev-build? It’s safe to use it on production sites – I only made a small change to the when the code snippet is executed.

    https://github.com/MapSteps/Page-Builder-Framework/archive/refs/heads/master.zip

    You will have to rename the downloaded/unzipped file to page-builder-framework and replace it with the page-builder-framework folder in your wp-content folder.

    Best,
    David

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘After latest update 2.6.20 woocommerce only shows one product per col’ is closed to new replies.