Support » Plugin: Salt Shaker » after last update

  • Resolved mythos77

    (@mythos77)


    Hi
    i have one issue after I update the salt shaker.
    in debug log i have many this warning. And every second increase.

    Warning: feof() expects parameter 1 to be resource, bool given in /wp-content/plugins/salt-shaker/_inc/core.class.php on line 62
    Warning: fgets() expects parameter 1 to be resource, bool given in /wp-content/plugins/salt-shaker/_inc/core.class.php on line 63

    $replaced = false;
                    while (!feof($readin_config)) {
                        $line = fgets($readin_config);
                        if (stristr($line, $salt_value)) {
                            $line = $new_salts[$salt_key] . "\n";
                            $replaced = true;

    It is possible stop this script?
    I coming crazy when must every time delete.

    Thank you

    • This topic was modified 11 months, 1 week ago by mythos77.
Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Nagdy

    (@nagdy)

    Thanks @mythos77,

    I’m checking this issue and I’ll update as soon as possible.

    Plugin Author Nagdy

    (@nagdy)

    I’m not able to reproduce the same issue on my different tests. Could you please check if the plugin itself is working fine on your installation?

    I think it does not work because this means the ‘resource’; in this case, the config file is not accessible.

    mythos77

    (@mythos77)

    Dear Nagdy,
    I am update plugin but the issue stay. Which config? You mean wp-config?

    mythos77

    (@mythos77)

    Dear Nagdy,
    I am using
    Server: Apache
    PHP: v7.3.0 GD: bundled (2.1.0 compatible)
    MYSQL: v10.3.8-MariaDB-1:10.3.8+maria~xenial-log

    When you need something more please write me.
    Thanx

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    Sigh. Now I need to review and remove all of the author’s replies…

    @nagdy I’ve deleted your offer to login to your user’s site. I’m am 100% sure you mean well but please never ask for credentials. I have flagged your account temporarily. That just means that your post will need to be approved and @ notifications from you will not work.

    https://wordpress.org/support/guidelines/#the-bad-stuff

    Now for the why: The internet is a wonderful place full of very nice people and a few very bad ones. I’m sure everyone here is very nice however, by giving some ones keys to your house you are trusting they wont steal anything. Likewise the person who takes the keys is now responsible for the house FOREVER.

    If something was to go wrong, then you the author may well legally become liable for damages, which they would not normally have been as their software is provided without warranty.

    Please be aware that repeatedly asking for credentials will result in us asking you to repeatedly stop before escalating up to the plugins team.

    It’s never necessary.

    There are many ways to get information you need and accessing the user’s site is not one of them. That’s going too far.

    You get the idea.

    Volunteer support is not easy. But these forums need to a safe place for all users, experienced or new. Accessing their system that way is a short cut that will get you into real trouble in these forums.

    Plugin Author Nagdy

    (@nagdy)

    Thanks Jan, I’m aware of all of that (except the health check plugin thingie) and agree with you but I guess you missed (or you were not fully aware) that I asked for a staging environment where the issue is reproducible not the live site. Anyway, it seems that my account likes to be flagged 😀

    Back to the issue here, well, could you please test the following:
    1- Via FTP, download your wp-config.php file and notice the salt keys.
    2- Go to Salt shaker settings and change the keys.
    3- Download the wp-config.php again and see if the salts are changed.

    Please let me know.

    mythos77

    (@mythos77)

    @nagdy
    yes is changed

    • This reply was modified 11 months ago by mythos77.
    Plugin Author Nagdy

    (@nagdy)

    This is becoming weird, this means the file is readable and writable. Well, I’ll check the error logs for a few sites where Salt Shaker is active and get back to you.

    mythos77

    (@mythos77)

    @nagdy
    ok, thanx.
    I have installed health check on my site when need some info please write me.

    @nagdy
    any news with issue?
    Thanx

    Plugin Author Nagdy

    (@nagdy)

    Sorry for the late reply, @mythos77.

    I have checked every website I have with Salt Shaker installed and I did not find anything in the log files. Then I updated to PHP 7.3 and hoped to reproduce the issue but everything is still working fine and the log files still clean.

    Thank you for your reply @nagdy
    today i use trobleshooting from health check that turn off plugins, but the issue still there. When I search in internet somthing about this issue I found only this.

    https://stackoverflow.com/questions/26148683/warning-fgets-expects-parameter-1-to-be-resource-string-given-in

    But I dont now how to aplicate.

    mythos77

    (@mythos77)

    Dear @nagdy ,
    today I update the woocommerce plugin and the issue is gone.I hope for ever.

    Plugin Author Nagdy

    (@nagdy)

    Oh that’s weird and great 🙂

    Good luck with your project, @mythos77

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘after last update’ is closed to new replies.