Support » Plugin: Really Simple SSL » After installing really simple SSL can’t log into wordpress admin panel

  • After i’ve installed plugin “Really Simple SSL” can’t log into admin panel in WordPress. I get the following error: “Sorry, you are not allowed to access this page.”

    Have already changed all URL’s in database.

    • This topic was modified 2 years, 8 months ago by  johnmcmuffin.
Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author RogierLankhorst

    (@rogierlankhorst)

    After activating SSL, your domain has changed. If you then try to reload the page, WordPress does not recognise your cookies anymore, so thinks you’re logged out. If you clear your cache, then login again, the error should go away.

    If you want to deactivate instead, please follow these instructions. https://really-simple-ssl.com/knowledge-base/uninstall-websitebackend-not-accessible/

    Clear cache (even trying to log into thorught private tab) still the same

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Did you do the manual change of the url’s before or after the issue started? And did you only change the site_url and home_url? There have been no reports, except yours, of this issue, so I need some more details to understand how this could have been caused by a change to SSL. Is your front-end still up?

    When activated, Really Simple SSl does four things:
    – adds a .htaccess redirect
    – changes home_url and site_url to https
    – activates mixed content fixer
    – If needed, inserts a fix in the wp-config.php

    Instead of the quick rollback from the other link, you could also remove these changes step by step, so you can see which of these steps causes your issue.
    More extensive description of these steps:
    https://really-simple-ssl.com/knowledge-base/when-the-built-in-deactivation-does-not-work-manual-uninstalling/

    These steps will completely remove any changes Really Simple SSL has made.

    Using nginx+apache, where i’ve got ssl on nginx. I’ve activated plugin and that’s all. Home url and site url were changed in database cause after i’ve activated plugin i can’t get to the admin panel.

    P.S. Plugin can’t write something in .htaccess, so – adds a .htaccess redirect – what exactly i should add?
    I’ve add

    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
    </IfModule>

    Thanks for help

    • This reply was modified 2 years, 8 months ago by  johnmcmuffin. Reason: find out what should i add
    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    If there’s no .htaccess, you can skip that step. So if you rename the plugin folder, then remove the wpconfig.php edit the plugin might have made, you’ve rolled back all changes.

    If there is Varnish caching activated on the server, you might need to deactivate that too, temporarily, because Varnish often has issues when on SSL.

    When i’ve removed `define(‘FORCE_SSL_ADMIN’, true);
    if (isset($_SERVER[“HTTP_X_FORWARDED_PROTO”] ) && “https” == $_SERVER[“HTTP_X_FORWARDED_PROTO”] ) {
    $_SERVER[“HTTPS”] = “on”;
    }`
    site start working again as there is no ssl and when i’m trying i’ve an error (an error occurred till i didn’t replace https to http in database)

    BTW i’ve found that error occurred even if i’m not using your plugin (just changing in wordpress’ settings http to https and add to wp-config `define(‘FORCE_SSL_ADMIN’, true);
    // in some setups HTTP_X_FORWARDED_PROTO might contain
    // a comma-separated list e.g. http,https
    // so check for https existence
    if (strpos($_SERVER[‘HTTP_X_FORWARDED_PROTO’], ‘https’) !== false)
    $_SERVER[‘HTTPS’]=’on’;`

    Plugin Author RogierLankhorst

    (@rogierlankhorst)

    Glad to hear it’s solved, and good to hear my plugin didn’t cause the issue. In that case, maybe you could reconsider the one star…

    By the way, I’d like to add that
    define(‘FORCE_SSL_ADMIN’, true)
    is not added by Really Simple SSL.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘After installing really simple SSL can’t log into wordpress admin panel’ is closed to new replies.