WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] after installation: failed to open stream:

[Resolved] after installation: failed to open stream:

  • hey! i have a brand new installation of wordpress on my brand new host! it worked fine and the database works (at least i can write and so on) but: the index shows the following error:

    Warning: require(./wp-blog-header.php) [function.require]: failed to open stream: No such file or directory in w:\www\holzen\index.php on line 4

    Fatal error: require() [function.require]: Failed opening required ‘./wp-blog-header.php’ (include_path=’.;W:\usr\php5\pear’) in w:\www\holzen\index.php on line 4

    i don’t know what’s wrong… all my files were uploaded correctly and the installation worked fine. i even installed it a couple of times.

    might it be my database name? it has a dash in it, but i don’t ave rights to change it. the chmod of all files is set to 666. is that alright?

    thanks a lot
    niklas

Viewing 6 replies - 1 through 6 (of 6 total)
  • Under Options:General what is in your
    WordPress address (URI):
    Blog address (URI):
    ?

    Using permalinks?

    Is wp-blog-header.php there?

    wp-blog-header.php is there, i am using permalinks based on the date (i can change it around, but it won’t help) and both blog and wp URIs are http://www.holzenetz.com

    thanks…
    (i’m frustrated here…)

    Hang on, hopefully someone more familiar with Windows servers will notice this.

    (I was going to ask about your .htaccess next ;’)

    Oh, and post a link too.

    windows server indeed 😉 my page was on some unix based server before.

    my .htaccess is not even configured – so, it should be alright. http://www.holzenetz.com is my page. my host is http://www.knallhart.de. i’m trying to google for a solution but nobody seems to have this problem 😉

    YES!!!!!!! got it.
    ok, i modified the index file by leaving out the ./ part in front of the “require”-tag. now everything is working perfectly! man, this makes my day. thanks a lot!

    <?php
    /* Short and sweet */
    define(‘WP_USE_THEMES’, true);
    require(‘wp-blog-header.php’);
    ?>

    All the best!
    Niklas

    Cool!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] after installation: failed to open stream:’ is closed to new replies.