WordPress.org

Forums

[resolved] After install, visiting site opens a download box (4 posts)

  1. meenainc
    Member
    Posted 3 years ago #

    I just uploaded all the files to news.surecutblades.com but when you visit it, it downloads an empty file. I use Chrome so it appears as "download" in the lower bar.

    For some background, I host http://www.surecutblades.com with MediaTemple but since Highwire Commerce hosts our store, we changed the www A record DNS to point to Highwire's IP. However, we are still able to access our webmail because the webmail.surecutblades.com DNS record points to the MediaTemple IP. So in my DNS settings I added an A record for news.surecutblades.com to point to the MediaTemple IP that we host.

    And to make sure our DNS records were set correctly, I uploaded a test html file and could read it just fine. See for yourself by visiting news.surecutblades.com/indextemp.html

    Any suggestions?

  2. Tim S
    Member
    Posted 3 years ago #

    Hi meenainc,

    You may need to check your hosting provider. When you visit the index.php file it downloads a copy. I've seen his happen when the handler for php is not set correctly.

    I hope this helps!

    Tim S.

  3. meenainc
    Member
    Posted 3 years ago #

    Thanks Tim but can you clarify what the handler is? When we installed wordpress on the root domain (before we moved to Highwire) wordpress worked fine...now that we have installed it on a subdomain, we are having issues. Just curious to know if there is a setting in our Plesk we need to change for it to work on a subdomain.

    Thanks again!
    Meena

  4. meenainc
    Member
    Posted 3 years ago #

    I got it!! The PHP support was not checked during the domain setup.... I have done 30+ of these and that's the first time we missed that little box.... embarrassed!

    Thanks for the help!

Topic Closed

This topic has been closed to new replies.

About this Topic