UpdraftPlus WordPress Backup Plugin
[resolved] After install "Site has been suspended or archived" (7 posts)

  1. contool
    Posted 2 years ago #

    I installed Updraft Plus (free version) yesterday on my WPMS to test it out. All seemed to go well and I conected Google Drive to make my first back up. My site is privately hosted at http://www.firouzeh.co.uk (i.e. not wordpress.com where this issue usually occurs)

    I tried to access my site again today and was shown the error "This site has been archived or suspended." I have checked my database and can confirm that the site was not accidentally archived (wp_blogs archived = 0). I have also contacted my server and can confirm they have not suspended my account.

    Occasionally this issue occurs with people who have hosted their sites on wordpress.com - which is not my case, however there seems to be a bug that is throwing up a same error.

    Would appreciate any insight you have into a fix as the backup system seems perfect. For the meantime I am restoring to a version from August which is a bit out of date.

    All the best


  2. contool
    Posted 2 years ago #

    Edit: Also cannot access WP dashboard - site is completely locked down

  3. David Anderson
    Plugin Author

    Posted 2 years ago #

    Hi contool,

    UD doesn't have any code that interacts with that part of WordPress (code that enables/disables sites would be an odd thing to have in a backup plugin), so I think you're having an other problem and a timing co-incedence. (UD presently gets downloaded 4,000 times a day, so timing co-incedences are expected to happen now and again).

    Anyway, I had a look in the WordPress code base to see where that message comes. It's in ms-load.php, and here's the fragment:

    if ( $blog->archived == '1' || $blog->spam == '1' ) {
    if ( file_exists( WP_CONTENT_DIR . '/blog-suspended.php' ) )
    return WP_CONTENT_DIR . '/blog-suspended.php';
    wp_die( __( 'This site has been archived or suspended.' ), '', array( 'response' => 410 ) );

    So, either your blog is marked as archived, or marked as spam, or the file 'blog-suspended.php' exists in the blog's content directory. It sounds like you looked at one of those 3 causes, but not the other 2.


  4. baptiste
    Posted 2 years ago #

    I encountered the same problem. During the 3.7.1 upgrade of the database, all my sites got set to 'archived'. In the wp_blogs table, I changed all the archived fields from 1 to 0 and voila! Sites working again.

  5. contool
    Posted 2 years ago #

    Hi David. Thanks for the reply - if it's an isolated case something else must have happened. Unfortunately I had to do a quick fix to get the site back up so not sure whether the site was marked as spam, but could well have been the case.

    Restored an old copy of my DB via the server and it seemed to fix the issue.


  6. contool
    Posted 2 years ago #

    Thanks baptiste. After I restored an old version of the DB I was able to access the WP dashboard and discovered that my 2 sites were indeed archived (access through the DB probably would have shown the same). Slightly confusing because I had never manually archived them even before the restore point. I unarchived and the sites are back up.

    Thanks for the help.

  7. David Anderson
    Plugin Author

    Posted 2 years ago #

    Hi baptiste,

    I'm not yet seeing any reason why this has been posted in the UpdraftPlus forum, rather than in a general forum, as an issue that's coming up whilst upgrading to WordPress 3.7. I'd rather not have everybody pile into this thread until there's some indication that it's something to do with UpdraftPlus. UpdraftPlus doesn't have any code that runs during a WP upgrade, or that touches individual columns in the wp_blogs table.


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • UpdraftPlus WordPress Backup Plugin
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.