Support » Plugin: IP2Location Country Blocker » After I install IP2Location Country Blocker but I cannot set up your plugin

  • Resolved ly070

    (@ly070)


    Hi Guys,

    after I install IP2Location Country Blocker plugin I have download ip country and finished download but when I try to click on Country Blocker on left menu it shows the text error below and I cannot set up your plugin.

    There has been a critical error on this website. Please check your site admin email inbox for instructions.

    Learn more about debugging in WordPress.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author ip2location

    (@ip2location)

    Can I know what instructions given in the email you received?

    Thread Starter ly070

    (@ly070)

    Hi Guys,

    Please the detail below that I received.

    Howdy!

    Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

    In this case, WordPress caught an error with one of your plugins, IP2Location Country Blocker.

    First, visit your website (http://mydomain.com/) and check for any visible issues. Next, visit the page where the error was caught http://mydomain.com/wp-admin/admin.php?page=ip2location-country-blocker) and check for any visible issues.

    Please contact your host for assistance with investigating this issue further.

    If your site appears broken and you can’t access your dashboard normally, WordPress now has a special “recovery mode”. This lets you safely login to your dashboard and investigate further.

    http://mydomain.com/wp-login.php?action=enter_recovery_mode&rm_token=m6firlTDTG47JWNxSWW&rm_key=UzswIahPW0G2w9EgQ0qeU

    To keep your site safe, this link will expire in 1 day. Don’t worry about that, though: a new link will be emailed to you if the error occurs again after it expires.

    When seeking help with this issue, you may be asked for some of the following information:
    WordPress version 5.4.4
    Current theme: My Theme (version 1.1)
    Current plugin: IP2Location Country Blocker (version 2.25.4)
    PHP version 7.0.33

    Error Details
    =============
    An error of type E_PARSE was caused in line 34 of the file /home/mydomain/public_html/wp-content/plugins/ip2location-country-blocker/vendor/ip2location/ip2proxy-php/class.IP2Proxy.php. Error message: syntax error, unexpected ‘const’ (T_CONST), expecting variable (T_VARIABLE)

    Plugin Author ip2location

    (@ip2location)

    You may need PHP 7.1 and above to use this plugin. We released a new version to support lower version PHP.

    Thread Starter ly070

    (@ly070)

    Hi Guys,

    It’s working now thank a lot for your support.

    Thank you,

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘After I install IP2Location Country Blocker but I cannot set up your plugin’ is closed to new replies.