WordPress.org

Support

Support » Alpha/Beta » [Resolved] after enabling multisite, my-sites.php gives empty page

[Resolved] after enabling multisite, my-sites.php gives empty page

  • Frits1980
    Member

    @frits1980

    In WP 3.0 Alpha

    After doing all settings in wp-config.php and .htaccess I get the new option my sites in my dashboard, as I was used to in MU. But when I click it it gives an empty page.

    Anyone ideas?

Viewing 15 replies - 1 through 15 (of 21 total)
  • There were (or are) some problems but see if Andrea’s info here helps:
    http://codex.wordpress.org/User:Andrea/Create_A_Network

    Frits1980
    Member

    @frits1980

    Hi MichaelH,

    Followed the whole tut step by step, just to be shure I didn’t screw up the first time… But still nothing.

    Other thing I came up with. At the end of the tut Andrea I talking about a menu item called: “Super admin”
    I only get “My sites” as a child item of the dashboard.
    When I press that I still get the empty page…

    I also found out that the appearances page is screwed after doing this.
    As seen in the screendump: Screendump

    Thank you for your help.

    Frits1980
    Member

    @frits1980

    Ok. Dived into the code and found the solution to this problem.

    When you edit the wp-config.php file to put in the code for the multisite, make shure you add those lines before these lines:

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    Otherwise it won’t work due to missing ms-functions.php file.

    I just upgraded to the latest trunk, then I undid the enabled network.

    define ('WP_ALLOW_MULTISITE', true ) ;

    Should be added to the wp-config.php to show you the network menu item under Tools.

    THEN, you have to go through the network setup and add what it tells you.

    After that, a Super Admin menu shows up when you refresh your admin screen. you must be logged in as the main admin for the blog.

    I’ll run through this again this afternoon.

    Must’va had a glitchy version. worked fine for me.

    lokrin2000
    Member

    @lokrin2000

    http://wordpress.org/support/topic/377729?replies=2

    I’m still having the same problem as listed in the above thread. I’ve double checked everything in this thread including the link listed above.

    I have the my sites link and I’ve updated the wp-config.php and .htaccess files and I still get the same error message.

    Frits1980
    Member

    @frits1980

    @andrea, it worked fine after putting the code in de wp-config file right before the require of the wp-settings.php file.
    I expect developers make this just like I used in wordpress on official release. With one push on a button, instead of editing php files…

    @lokrin2000, I didn’t use admin as first user and still it worked. So I don’t think that could be the reason of your problems. I think you still have the same problems as I had. Because all the functions your wordpress can’t find are located in the ms-functions.php file. Which is called in the wp-settings.php file.
    Can you make sure the wp-settings.php file is called after your multisite settings in the wp-config.php file.

    lokrin2000
    Member

    @lokrin2000

    I had
    require_once(ABSPATH . ‘wp-settings.php’);
    at the beginning of the multisite lines in wp-config.

    Everything is ok now. Thanks.

    cinematic
    Participant

    @cinematic

    I put
    require_once(ABSPATH . 'wp-settings.php');
    before
    define ('WP_ALLOW_MULTISITE', true ) ;
    Then I couldn’t login any more and got the message
    “You don’t have sufficient permissions to do that.”

    After installing the network settings everything worked fine with this line added at the beginning of the multisite lines.

    I had the same problem as here: pages rendered blank or only semi-rendered. After moving the line require_once(ABSPATH . 'wp-settings.php'); to the end of the wp-config.php file, where it now resides right after define ('WP_ALLOW_MULTISITE', true); and the rest of the multisite-code, the problem was fixed.

    IMO, Andrea’s (otherwise very good) document doesn’t mention this. Maybe it should?

    That’s an interesting problem. I say that because in wp-config-sample.php (and in all builds of WP I’ve ever seen), the last few lines of the file look like this:

    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
            define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    Now, that implies, to ME at least, that any changes you make should ALWAYS happen above that section. Perhaps that needs to be made more explicit: DO NOT EDIT OR ADD LINES BELOW THIS!

    .. and further above there’s an inline comment that says “add your extra stuff here below this line” or similar.

    I’m paraphrasing here. 😉

    I could add a remind to not add these to the end of the file though. A full create a network page now exists in the codex. (thanks whoever bumped it live 🙂 )

    it might make sense to include the allow multisite line by default, disabled as a comment. with a statement above that says to remove //. that way nobody would put it in the wrong place! (saving the forums a lot of heartache)

    /**
     * Multisite
     * Remove // below to begin Multisite setup.
     * Add config provided by WP immediately below.
     */
    // define ('WP_ALLOW_MULTISITE', true ) ;

    Wouldn’t help anyone doing upgrades, though.

    If you look back far enough in trac, things like that *were* in there, but it was decided to remove it because the majority of users don’t need it.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Resolved] after enabling multisite, my-sites.php gives empty page’ is closed to new replies.