WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] After editing .htaccess my site will not show up!

[Resolved] After editing .htaccess my site will not show up!

Viewing 11 replies - 1 through 11 (of 11 total)
  • http://sillsspolintheaterworks.com/wp-admin is still available, it looks like. Go in and change permalinks to default (ugly)

    now that I think about it – I think the site might be down after a failed WordPress update.

    I’m trying to do a manual update but it seems my plugin and themes folders are inaccessible. Any idea why that happened?

    Is there any way to fix that?!

    To be more specific, the “plugins” “themes” and “uploads” folders do not even show as folders anymore – they just look like files.

    esmi

    @esmi

    Forum Moderator

    Are you sure that there isn’t an issue with your server? Have you tried contacting your hosts?

    Yes, I have contacted them via email but I’m hoping to figure it out asap.

    In your experience have you seen something like this before?

    Fortunately, I can still access all of the pages/posts in the admin. I just can’t see any plugins or themes…

    I see these errors on the themes page:

    Warning: array_keys() [function.array-keys]: The first argument should be an array in /home/sillsspo/public_html/wp-includes/theme.php on line 519

    Warning: uksort() [function.uksort]: The argument should be an array in /home/sillsspo/public_html/wp-admin/includes/class-wp-themes-list-table.php on line 49

    Warning: array_slice() expects parameter 1 to be array, boolean given in /home/sillsspo/public_html/wp-admin/includes/class-wp-themes-list-table.php on line 56

    esmi

    @esmi

    Forum Moderator

    The problem you describe with your plugins, themes and uploads folders is well outside of the control of WordPress. It does sound like there’s something seriously wrong with the server but it’s not something I’ve personally seen before.

    I’m wondering if I just overwrite the themes folder and re-upload the theme if it will work? I’m kind of nervous to do that – but if it gets the site back up then maybe it’s worth a try.

    esmi

    @esmi

    Forum Moderator

    Right now, I wouldn’t like to hazard a guess as to what will happen but I very much doubt that it would make things worse.

    Ok – I realized that when the manual update I was uploading the 3.1.1 version of the files. So I started over with the newest WordPress 3.1.2 and now it’s all working again.

    Thanks for trying to help.

    esmi

    @esmi

    Forum Moderator

    Glad to hear that you managed to get it sorted. 🙂

    Also – for anyone who has similar problems – it turns out my permission settings for the wp-content directory were causing issues and making those files inaccessible which was making my site blank.

    I had the permissions set to 666 but once I changed them to 755 it worked!!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] After editing .htaccess my site will not show up!’ is closed to new replies.
Skip to toolbar