WordPress.org

Forums

Frontier
[resolved] After content widgets - side by side? (8 posts)

  1. meadwench
    Member
    Posted 10 months ago #

    Can the after content widgets (3) be set up as side-by-side instead of one after the other?

  2. ronangelo
    Member
    Theme Author

    Posted 10 months ago #

    With CSS you can try to apply a certain width percentage on the widgets. Then add float to make them appear side-by-side. float: left; width: 33.33%;

  3. meadwench
    Member
    Posted 10 months ago #

    Thanks! sorry for the delay, I've been on vacation and off the grid for 2 weeks.

    I went to look at the code to grab the right section to put in the custom file, and it shows that area as widget-wrap-after-content. However, the css file only has widget-after-post-content. Am I missing some css code somewhere?

  4. meadwench
    Member
    Posted 9 months ago #

    Just checking in, to make sure that the widgets I want to alter are the right ones. What widget css applies to the ones directly under the content?

    Thanks!

  5. ronangelo
    Member
    Theme Author

    Posted 9 months ago #

    Try adding this on the option page's Custom CSS tab:

    .widget-after-post-content {
       float: left;
       width: 33.33%;
    }
  6. meadwench
    Member
    Posted 9 months ago #

    Hmm. That didn't work, so I went and looked at the code again with Firebug, and it was widgets-after-content. Altered the css and that worked. http://www.sivb.net .

    Thanks!!

    I wanted a white background, and added background-color: white; to the code, and only the first one changed, which is weird.

    I checked firebug again, and they are all showing that as the widget name, but only the first one changed. There is no background color in my code within the widget itself.

    Ideas?

  7. ronangelo
    Member
    Theme Author

    Posted 9 months ago #

    Hmm. That didn't work, so I went and looked at the code again with Firebug, and it was widgets-after-content

    Since you mentioned the word content, I assumed you meant the widget that's after/below the content. The one you wanted was the widget after/outside the post.

    I checked firebug again, and they are all showing that as the widget name, but only the first one changed. There is no background color in my code within the widget itself.

    Check the CSS codes you've added on the Custom CSS tab. You've set a bg color for 3 text widgets just before you've added the bg color for .widget-after-content.

  8. meadwench
    Member
    Posted 9 months ago #

    thank you sir, that did the trick!

Reply

You must log in to post.

About this Theme

About this Topic

Tags

No tags yet.