Support » Fixing WordPress » After active Child theme i can’t display preview pages, etc

  • [ Moderator note: moved to Fixing WordPress. ]

    Hi,

    i have created a child theme only with a basic style.css and function.php and i can create pages but when i try to preview them only appears a white page. IF i chage to parent theme (Zerif lite) all is running correctly.

    Any Idea?

    Regards.

    /*
    Theme Name: zerif lite child
    Theme URI: https://es.wordpress.org/themes/zerif-lite/
    Description: Zerif Lite Child Theme
    Author: Grupo Alermarsof
    Author URI: http://www.example.ecom
    Template: Zerif-lite
    Version: 1.0.0
    License: GNU General Public License v2 or later
    License URI: http://www.gnu.org/licenses/gpl-2.0.html
    Tags: light, dark, two-columns, right-sidebar, responsive-layout, accessibility-ready
    Text Domain: Zerif-lite-Child
    */

    <?php
    function my_theme_enqueue_styles() {

    $parent_style = ‘parent-style’; // This is ‘twentyfifteen-style’ for the Twenty Fifteen theme.

    wp_enqueue_style( $parent_style, get_template_directory_uri() . ‘/style.css’ );
    wp_enqueue_style( ‘child-style’,
    get_stylesheet_directory_uri() . ‘/style.css’,
    array( $parent_style ),
    wp_get_theme()->get(‘Version’)
    );
    }
    add_action( ‘wp_enqueue_scripts’, ‘my_theme_enqueue_styles’ );
    ?>

Viewing 4 replies - 1 through 4 (of 4 total)
  • If you’re getting a white page, you most likely have a PHP error in your child theme’s functions.php. The way you display it above, it’s difficult to tell if you have a line break in that first comment that might be causing a problem. It’s best if you put code in code tags here. You might try the following in your functions.php to enqueue your child theme’s style sheet:

    
    add_action('wp_enqueue_scripts', 'load_my_child_styles', 20);
    function load_my_child_styles() {
        wp_enqueue_style('child-theme', get_stylesheet_uri());
    }
    

    Many themes will do it for you, but if you find that your parent theme’s style sheet isn’t included without it, you can add the following to your functions.php:

    
    add_action('wp_enqueue_scripts', 'enqueue_parent_theme_style');
    function enqueue_parent_theme_style() {
    	wp_enqueue_style('parent-style', get_template_directory_uri() . '/style.css');
    }
    

    Hi,

    i put the code previous but the problem is the same. When i modify a page and click over preview button only appears white page but it is run without problem from outside admin site of the site.

    Any idea?

    <?php
    add_action(‘wp_enqueue_scripts’, ‘load_my_child_styles’, 20);
    function load_my_child_styles() {
    wp_enqueue_style(‘child-theme’, get_stylesheet_uri());
    }

    Two things I would check:

    1. Verify that both the child theme and parent theme are being loaded. You can do that by using your browser to look at the source code for your site. (In Firefox, it’s Ctrl+U.) If you provide a link to your site, I can take a look too.
    2. Look in the /public_html and /public_html/wp-admin folders of your site to see if you have an error_log file. If so, post its contents here so we can see if your problem is a PHP error.
    FGD

    (@creativetopia)

    I have a website using this theme (with child theme) and unable to preview posts. It redirects to the home page. In the process of debugging and troubleshooting now. Any luck with this?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘After active Child theme i can’t display preview pages, etc’ is closed to new replies.