Support » Plugin: WP Document Revisions » After activating the plugin, the Documents menu is not available

  • Resolved tomifocus

    (@tomifocus)


    After activating the plugin, the Documents menu is not available.
    I have tried to de-activate and re-activate, delete and re-install the plugin without success. Do you have any idea what can cause this issue? Do you have any solution for this case?

Viewing 3 replies - 1 through 3 (of 3 total)
  • I had the same issue.

    I solved it by creating a second admin account. The “Documents” menu is visible when logged into that account. I was never able to solve the issue on my original admin account???

    If someone else know the solution, I’d love to here it.

    Thread Starter tomifocus

    (@tomifocus)

    Thanks for your hint. I can confirm that after creating the second admin account the Documents menu was appeared. This points to the fact that the missing “Documents” menu issue will probably be caused by changed user roles.
    In my case I faced this issue after several plugins were installed for my WordPress site.
    So probably one of these plugins overwrote/changed the admin user roles under wp_usermeta database table. And WP Document Revisions plugin requires the default administrator user roles to display “Documents” menu in WordPress dashboard menu.
    Therefore I opened wp_usermeta database table, clicked on edit button at wp_capabilities of admin user and made a copy about the meta_value. Then overwrote the wp_capabilities meta_value with the default admin value: a:1:{s:13:”administrator”;b:1;}.
    Then the issue was resolved at the original admin user as well.
    Always make a backup before the manual database table modification that you can restore for the case if you would make any mistake. And after the modification test your wordpress site and the used plugins to know everything is working properly.

    @tomifocus,
    It is possible that what happened was that originally your administrator userid had not only the administrator role, but also another one that is explicitly NOT allowed to manage documents. In this case, the capability model may not allow you access despite the administrator access allowing the access.
    The action of either creating a new administrator user or manually removing the other role(s) by SQL update will ensure that no other role is removing the expected access – so you see the item in the menu.
    I found a similar effect with my usage of the plugin – which was why I made the change NOT to reset the capabilities when deactivating/reactivating the plugin that was released with v3.2.2. However this does mean that you must have the capabilities set up appropriately first.
    Hope this explains why you saw this as you did.

    @wpriley,
    Please check your original admin userid. It should have an additional role that does not permit them to manage documents so the menu item does not appear.

    Regards,
    Neil

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘After activating the plugin, the Documents menu is not available’ is closed to new replies.